[RFE] Bookmarks needs to remember charsets

VERIFIED WORKSFORME

Status

--
enhancement
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: chip, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
when bookmark a site, if mozilla is able to remember the language charset, it
will be a big plus for users those surf sites with different languages.  

For example, if I view a site which encoded in Traditional Chinese, and I set
the encoding to 'Traditional Chinese' via 'View->Character coding', after that,
I call a bookmark going to another site using Simplified Chinese, in some cases
(the site owner won't do the homework of setting the charset via HTTP header or
a META tag), I need to manual change the encoding again.

A quite annoying experience if I have to do that, even if the site has been
bookmarked.

It's also nice for bookmarks to remember the text-size (via view->text size) and
user-defined stylesheet (via view->stylesheets).  So that when an user bookmarks
a site, it also remembers all user settable settings, like what form
auto-completion is doing right now.

Thanks for the attention.  ;-)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

18 years ago
I can see the "attribute" string LAST_CHARSET="ISO-8859-1" in the bookmark
entries inside the bookmark file.

Is this attribute useful for this situation?  Any UI to utilize this info?
Worksforme...

reproduce:
1) go to www.mozilla.org
2) View->Character Coding-> (choose something.. I chose Korean)
3) Verify by opening the menu again that Korean is selected and is in the 
immediate first level list.
4) Bookmark site. 
5) Go to another page
6) Load bookmark
7) See that "Korean" (or whatever you chose) is selected in Character Coding 
menu. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Summary: [RFE] Bookmarks needs to remember charsets (and more!) → [RFE] Bookmarks needs to remember charsets
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.