Contacts unit tests are failing

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: rik, Assigned: alberto.pastor)

Tracking

unspecified

Firefox Tracking Flags

(b2g18 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
contacts_list_test.js is failing right now.

Alberto, ccing you since you are the module owner.
(Assignee)

Comment 1

6 years ago
I fixed them on bug 848188, but I'll try to push a quick commit later.

Thanks!
(Assignee)

Comment 2

6 years ago
Created attachment 736934 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9155

Pointer to Github pull-request
(Assignee)

Updated

6 years ago
Attachment #736934 - Flags: review?(anthony)
(Reporter)

Comment 3

6 years ago
Comment on attachment 736934 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9155

Great thanks. r+ with a small fix for one leak:
"global leak detected: asyncScriptsLoaded"
Attachment #736934 - Flags: review?(anthony) → review+
(Assignee)

Comment 4

6 years ago
oh right, will be fixed in a minute
(Assignee)

Comment 5

6 years ago
https://github.com/mozilla-b2g/gaia/commit/efec8783906d7dd3144ccdd4dd8381171050e900
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

6 years ago
Comment on attachment 736934 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9155

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
String or UUID changes made by this patch:

Only tests fixes. Travis will be happy with this merge
Attachment #736934 - Flags: approval-gaia-v1?
Andrew, I guess we can uplift this, is fixing the unit tests so travis won't stop in this error and will work properly.
Flags: needinfo?(overholt)
(In reply to Francisco Jordano [:arcturus] from comment #7)
> Andrew, I guess we can uplift this, is fixing the unit tests so travis won't
> stop in this error and will work properly.

For v1-train, right?  It sounds good to me and we'll make the call in the triage session starting in ~1 hour.
Flags: needinfo?(overholt)
Attachment #736934 - Flags: approval-gaia-v1? → approval-gaia-v1+
Andrew just asked for v1.0.1, do I need to add any other flag for v1-train?

Alberto commented he can do the uplift by himself.

Thanks!
status-b2g18-v1.0.1: --- → affected
(In reply to Francisco Jordano [:arcturus] from comment #9)
> Andrew just asked for v1.0.1, do I need to add any other flag for v1-train?
> 
> Alberto commented he can do the uplift by himself.
> 
> Thanks!

All changes on v1.0.1 must come from blocking (tef+) bugs.  The approval here is just for v1-train.
Patch does not cleanly apply to v1-train
Flags: needinfo?(nobody)
(Assignee)

Comment 12

6 years ago
v1-train: e5e3921871893c85feb342e38c58e7dae37bedb5
status-b2g18: --- → fixed
status-b2g18-v1.0.1: affected → ---
(Assignee)

Updated

6 years ago
Assignee: nobody → alberto.pastor
(Assignee)

Updated

6 years ago
Flags: needinfo?(nobody)
You need to log in before you can comment on or make changes to this bug.