Youtube video iframe not displayed on www.coursera.org due to mixed content blocking

RESOLVED FIXED in May

Status

Tech Evangelism
Desktop
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: hasna, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mcb-chrome30+][mcb-ie])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130411 Firefox/23.0
Build ID: 20130411030925

Steps to reproduce:

I browsed web pages that contains video iframe


Actual results:

there was blank space instead of the video frame


Expected results:

video frame should be displayed so I can click on it to play. 
Display is correct with 20 branch
(Reporter)

Comment 1

5 years ago
I was browsing my courses in www.coursera.org after logging in (https)
Here is a  sample source code that wasn't displayed

<iframe src="http://www.youtube.com/embed/DDW481EU7qc" allowfullscreen="" frameborder="0" height="315" width="420"></iframe><br>
FWIW, viewing above locally with plugins.click_to_play;true is WFM against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130414 Firefox/23.0 ID:20130414031025 CSet: ef802a6418f2

Does any other Flash Content work?
IS C2P active?

Updated

5 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
Could you please try the following :

1) try this with a clean profile: http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

2) running in Safe mode: http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Could you also please update your Flash and GPU driver?
Flags: needinfo?(hasna.sabah)
(Reporter)

Comment 4

5 years ago
I tested with clean profile and in safe mode, the problem is still here.
I looked for flash video directly in youtube/vimeo (by copying the links), I can then play them, so I think this  means no problem with flash player (I updated it too)

for C2P, do i need to install an extra  plugin ? isn't it enbaled by default?
Flags: needinfo?(hasna.sabah)
No, there is no need to install an extra plugin for C2P. It isn't enabled by default, unless you have plug-ins out of date.

If you want to enable C2P, you need to type about:config in the URL bar, hit Enter, and type in the Search box plugins.click_to_play, and set it to "true", by double clicking it.
(Reporter)

Comment 6

5 years ago
Thanks, I checked in the config, it's not enabled...but enabling it didn't help.
(Reporter)

Comment 7

5 years ago
Thanks, I checked in the config, it's not enabled...but I still have the same problem with or without this parameter enabled.
I can't reproduce this either on Ubuntu & OS X.

Does e.g. the video on this site work for you:
https://www.coursera.org/course/interactivepython
If that one works, could you please provide a full sample that breaks for you?

The most useful thing would be to find the regression range for this:
http://mozilla.github.io/mozregression/
As you say it worked on 20, but is broken in the current nightlies, so i think you can get going with --good=2013-01-06 and --bad=2013-04-12.
Flags: needinfo?(hasna.sabah)
(Reporter)

Comment 9

5 years ago
you can use these credentials 

login: hasna.sabah@openmail.cc
pass:  Azerty123

and go to this page :
https://class.coursera.org/behavioralecon-001/class/index

I use Fedora and my Nightly is up-to date 23.0a1 (2013-04-26)
Flags: needinfo?(hasna.sabah)
(Reporter)

Comment 10

5 years ago
I am not sure but I supsect some timeout : the page takes more time  to load under the 20 branch
You mean the intro video on the top right? 
That works fine for me on OpenSUSE with Nightly 2013-04-26 and Flash 11.2 r202.

Did you change any Flash settings?
So far i don't see what we could do here without more information, sorry.
(Reporter)

Comment 12

5 years ago
Created attachment 742474 [details]
screenshot of the problem
(Reporter)

Comment 13

5 years ago
Did you login and go to class ? the page is full of videos in the center that aren't displayed. I've attached a screenshot. I hope this will help.
Thank you
This is about Mixed Content Blocking.
Just click on the Doorhanger Icon (left of the Favicon in the URL Bar) and change "Keep Blocking" to "Disable Protection on This Page".
Blocks: 844556, 834836
Component: Plug-ins → Security
OS: Linux → All
Product: Core → Firefox
Hardware: x86 → All
Assignee: nobody → english-us
Component: Security → English US
Depends on: 776278
Product: Firefox → Tech Evangelism
Summary: video iframe not displayed → Youtube video iframe not displayed on www.coursera.org due to mixed content blocking
Target Milestone: --- → May
Version: 23 Branch → Trunk
(Reporter)

Comment 15

5 years ago
Done
The site needs to update its HTTP Vimeo links to be HTTPS.

These are the errors:

Blocked loading mixed active content "http://player.vimeo.com/video/61274633" @ https://class.coursera.org/behavioralecon-001/class/index
Blocked loading mixed active content "http://player.vimeo.com/video/61274632" @ https://class.coursera.org/behavioralecon-001/class/index
Blocked loading mixed active content "http://player.vimeo.com/video/61274631" @ https://class.coursera.org/behavioralecon-001/class/index
Blocked loading mixed active content "http://player.vimeo.com/video/61274630" @ https://class.coursera.org/behavioralecon-001/class/index
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mcb-chrome30+][mcb-ie?]
Whiteboard: [mcb-chrome30+][mcb-ie?] → [mcb-chrome30+][mcb-ie]

Updated

4 years ago
Component: English US → Desktop
I just tested, and videos are working for me. (The course in Comment #9 no longer exists)

Let's close as FIXED.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.