If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Dialer] The volume buttons have little to no effect on incoming volume during a call

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Dialer
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

({smoketest})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 736898 [details]
Log of call with volume adjustment attempts

Description:
If a user attempts to adjust the volume of incoming audio during a call, they will be unable to adjust the volume using the side buttons.  The volume meter will adjust itself with each button press, but the incoming volume will be unaffected.

Repro Steps:
1) Updated to Unagi Build ID: 20130412070204
2) Launch the Dialer app and make a call to another device.
3) Have the other device pick up the call and create some audio.
4) On the calling device, adjust the volume up and down using the side buttons.
5) Listen for a change in audio volume as the volume is being adjusted.

Actual:
Adjusting the volume during the call has no effect on the volume of the incoming audio.

Expected:
Adjusting the volume during the call increases or decreases the volume of the incoming audio.

Environmental Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/950db80b82cb
Gaia: 54ab4ce3f9107d1624c18bed2a09ace6bbc6601f

Notes:
Repro frequency: 100%
Test Suite Name: Firefox OS Daily Smoketest
UCID: dialer-000
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-id=1298
Q Analysts Test Team Priority: Pri 2
See attached logcat logs for more info.

Comment 1

5 years ago
Unable to reproduce issue for incoming ringer, outgoing ringer, and in-call volume.

Tested on Unagi Mozilla RIL:
Build ID: 20130416070203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2cc6a1c89a97
Gaia: f8e8f2be6803b02d6a083b2a144a80e7ebf15951

Recommend Worksforme
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

5 years ago
Verified Worksforme on Unagi 1.1 mozilla RIL.

Build ID: 20130430070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8ca8149ce236
Gaia: b525c25063d33d2e073d9f3e1e1164fadefec998
Version #: 18.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.