If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

/admin/videos/video2013/add/ throws 500 error

VERIFIED FIXED

Status

Websites
Firefox Flicks
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: mkelly, Assigned: mkelly)

Tracking

Details

(Assignee)

Description

5 years ago
Traceback (most recent call last):

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/core/handlers/base.py", line 136, in get_response
    response = response.render()

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/response.py", line 104, in render
    self._set_content(self.rendered_content)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/response.py", line 81, in rendered_content
    content = template.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 140, in render
    return self._render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 134, in _render
    return self.nodelist.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/loader_tags.py", line 123, in render
    return compiled_parent._render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 134, in _render
    return self.nodelist.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/loader_tags.py", line 123, in render
    return compiled_parent._render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 134, in _render
    return self.nodelist.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/loader_tags.py", line 123, in render
    return compiled_parent._render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 134, in _render
    return self.nodelist.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/loader_tags.py", line 62, in render
    result = block.nodelist.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/loader_tags.py", line 62, in render
    result = block.nodelist.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 823, in render
    bit = self.render_node(node, context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 837, in render_node
    return node.render(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 874, in render
    output = self.filter_expression.resolve(context)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/vendor/lib/python/django/template/base.py", line 599, in resolve
    new_obj = func(obj, *arg_vals)

  File "/data/www/firefoxflicks.mozilla.org/firefox-flicks/flicks/videos/templatetags/video_util.py", line 10, in embed_html
    return mark_safe(video.embed_html())

AttributeError: 'str' object has no attribute 'embed_html'

Comment 1

4 years ago
Commit pushed to master at https://github.com/mozilla/firefox-flicks

https://github.com/mozilla/firefox-flicks/commit/0dcd3441ca52e5d30d9a1e837a12de2ee1b12f9d
Fix Bug 861321: Don't embed video in admin if adding a new video.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Assignee: nobody → mkelly
Please confirm my last test didn't throw a traceback. I get a 403 page from the link above.
(Assignee)

Comment 3

4 years ago
There was no traceback, and I've confirmed myself that the page works (I forgot that you'd get a 403 because you don't have permission to access that page, whoops!).

Marking as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.