Closed Bug 861329 Opened 9 years ago Closed 9 years ago

Whitelist autoconfirmed accounts so that they never see captcha

Categories

(Websites :: wiki.mozilla.org, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lmandel, Assigned: AlisonW)

Details

I was reading the ConfirmEdit (wikimo captcha extension) docs to see if there was a way to alleviate some of the user pain from the addition of captchas to wikimo. ConfirmEdit provides the ability to whitelist accounts so that they never see the captcha. This can be achieved through the use of groups. I propose that we whitelist all autoconfirmed accounts and set some reasonable autoconfirm rules like 
account is > 90 days old
account has made > 50 edits

This can be achieved by adding/modifying the following lines to LocalSettings.php
$wgAutoConfirmAge = 86400*90;
$wgAutoConfirmCount = 50;
$wgGroupPermissions['autoconfirmed']['skipcaptcha'] = true;

Yes, there will be some old spam accounts. It seems to me that it will be relatively easy to identify and remove these accounts as they add spam. New spammers will have to then wait months before they can start autospamming the wiki again, at which point their account can again be removed.
Because, at present, every newly-created account is tagged as auto-confirmed this is not an option. 

However, a new setting for confirming and auto-confirming accounts in currently being added to the wiki and once the bulk of spammers are removed (we have over 200,000 of them it seems) a 'skipcaptcha' will be introduced with a low verification requirement. 

If you have any further queries please re-open.
Assignee: nobody → tech
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.