Closed Bug 861333 Opened 7 years ago Closed 7 years ago

TEST-UNEXPECTED-FAIL | browser_dataman_basics.js | The correct number of domains is listed - Got 19, expected 18

Categories

(SeaMonkey :: Passwords & Permissions, defect)

x86_64
Windows 8
defect
Not set

Tracking

(seamonkey2.19 fixed)

RESOLVED FIXED
seamonkey2.20
Tracking Status
seamonkey2.19 --- fixed

People

(Reporter: mcsmurf, Unassigned)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

The browser_dataman_basics.js test fails because the number of default domains changed from 18 to 19. I thought I saw the checkin which changed this, but I can't find it anymore:
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/dataman/
tests/browser_dataman_basics.js | After search, the correct number of domains is
 listed - Got 19, expected 18
Stack trace:
[...]

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/common/dataman/
tests/browser_dataman_basics.js | The IPv6 domain has been removed from the list
 - Got 18, expected 17

and a few other test fails.
Attached patch PatchSplinter Review
Robert: Bug 722299 added a new host to build/pgo/server-locations.txt, which changes the number of hosts in data manager (as a host with xbl/xul privs was added). That bug also changed the IDN algorithm, some xn--... host is now displayed as exämple.test. That is why I needed to change some numbers in the test. But the new host that was added serves as replacement as that one is still displayed in punnycode notation.
Attachment #737009 - Flags: review?(kairo)
Attachment #737009 - Flags: review?(kairo) → review+
Pushed: https://hg.mozilla.org/comm-central/rev/758434b4079b
Target Milestone: --- → seamonkey2.20
Comment on attachment 737009 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): Bug 722299
User impact if declined: none, test-only fix
Testing completed (on m-c, etc.): Works on comm-central
Risk to taking this patch (and alternatives if risky): none, test-only fix
String changes made by this patch:
Attachment #737009 - Flags: approval-comm-aurora?
Attachment #737009 - Flags: approval-comm-aurora? → approval-comm-aurora+
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.