If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent test_click.py TestClick.test_click | AssertionError: 'Clicked' != u'Click me!'

RESOLVED DUPLICATE of bug 838607

Status

Testing
Marionette
RESOLVED DUPLICATE of bug 838607
5 years ago
5 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86_64
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=21752487&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-04-12 07:41:37 PDT for push fe1999ee55af
slave: tst-linux64-ec2-322

14:43:10     INFO -  FAIL: test_click (test_click.TestClick)
14:43:10     INFO -  ----------------------------------------------------------------------
14:43:10     INFO -  Traceback (most recent call last):
14:43:10     INFO -    File "/builds/slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit/test_click.py", line 14, in test_click
14:43:10     INFO -      self.assertEqual("Clicked", self.marionette.execute_script("return document.getElementById('mozLink').innerHTML;"))
14:43:10     INFO -  TEST-UNEXPECTED-FAIL | test_click.py TestClick.test_click | AssertionError: 'Clicked' != u'Click me!'
14:43:10     INFO -  ----------------------------------------------------------------------
14:43:10     INFO -  Ran 2 tests in 3.398s
14:43:10     INFO -  FAILED (failures=1)
(Reporter)

Comment 1

5 years ago
Hmm, and again in https://tbpl.mozilla.org/php/getParsedLog.php?id=21753177&tree=Mozilla-Inbound on the same push, suspicious.
(Reporter)

Comment 2

5 years ago
Appears to have been caused by busted Puppet producing busted test slaves.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Comment hidden (Treeherder Robot)
Or not?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
So, this is really bug 838607, and this was exposed when I disabled another test_click.py test.  I've just disabled that test as well, so I'm duping this.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 838607
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.