Set up nightly-1.0.1 update channel

RESOLVED FIXED

Status

Release Engineering
General Automation
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: catlee, Assigned: catlee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g])

Attachments

(6 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Nightly builds on mozilla-b2g18_v1_0_1 need to be built with a new channel ('v1.0.1-nightly'?)

The b2g update server needs to handle these updates as well.
(Assignee)

Comment 1

5 years ago
Created attachment 738057 [details] [diff] [review]
add --update-channel cmdline option
Attachment #738057 - Flags: review?(aki)

Comment 2

5 years ago
Comment on attachment 738057 [details] [diff] [review]
add --update-channel cmdline option

Yeah, we'll probably need to get more config items out of nested lists/dictionaries as we want to override them via commandline or a 2nd config file.  Upload servers come to mind, for staging.
Attachment #738057 - Flags: review?(aki) → review+
(Assignee)

Updated

5 years ago
Duplicate of this bug: 862391
(Assignee)

Updated

5 years ago
Attachment #738057 - Flags: checked-in+

Updated

5 years ago
Blocks: 860355
(Assignee)

Comment 4

5 years ago
Created attachment 738077 [details] [diff] [review]
Set hamachi, unagi, otoro and inari builds on mozilla-b2g18_v1.0.1 to use nightly-1.0.1 update channel
Attachment #738077 - Flags: review?(aki)

Updated

5 years ago
Attachment #738077 - Flags: review?(aki) → review+
(Assignee)

Updated

5 years ago
Depends on: 862526

Comment 5

5 years ago
Merged the mozharness patch to production.

Comment 6

5 years ago
(In reply to Aki Sasaki [:aki] from comment #5)
> Merged the mozharness patch to production.

so is this resolved yet?   can it be tested now on 1.0.1 branches for all supported devices?
(Assignee)

Comment 7

5 years ago
No, it's not ready yet.
(Assignee)

Comment 8

5 years ago
Created attachment 745148 [details] [diff] [review]
Add nightly_update_channel config option; make sure we're updating the URL in the update.xml properly

After lots of discussion and testing, I've decided to change the update URL slightly.

Our nightly device builds will query URLs like http://.../unagi/1.0.1/nightly
Dep builds will have the update channel set to 'default', and so won't get updates. This matches how Firefox Desktop and Mobile builds are done.

I need to make corresponding changes to b2g_config.py, and possibly configs/b2g/releng*.py to enable updates for other devices/branches.
Attachment #738077 - Attachment is obsolete: true
Attachment #745148 - Flags: review?(aki)

Comment 9

5 years ago
Comment on attachment 745148 [details] [diff] [review]
Add nightly_update_channel config option; make sure we're updating the URL in the update.xml properly

If we ever get confused by any of the query_* logic (why we're falling through to 'default' or w/e), we can add some self.debug() or self.info() statements.
Attachment #745148 - Flags: review?(aki) → review+
(Assignee)

Comment 10

5 years ago
Created attachment 745371 [details] [diff] [review]
add mh config for private builds with updates

this is like releng-otoro.py, with updates enabled (like releng-beta.py)
Attachment #745371 - Flags: review?(aki)
(Assignee)

Comment 11

5 years ago
Created attachment 745372 [details] [diff] [review]
enable updates for inari

this will enable nightly updates for inari on all branches
we can enable updates for other devices once this works
Attachment #745372 - Flags: review?(aki)

Updated

5 years ago
Attachment #745372 - Flags: review?(aki) → review+

Updated

5 years ago
Attachment #745371 - Flags: review?(aki) → review+
(Assignee)

Updated

5 years ago
Attachment #745148 - Flags: checked-in+
(Assignee)

Updated

5 years ago
Attachment #745371 - Flags: checked-in+
(Assignee)

Updated

5 years ago
Attachment #745372 - Flags: checked-in+
(Assignee)

Comment 12

5 years ago
in production
https://tbpl.mozilla.org/php/getParsedLog.php?id=22640747&tree=Mozilla-B2g18

IOError: Can't find b2g/releng-private-updates.py in ['.', '/builds/slave/b2g_m-b18_inari_ntly-000000000/scripts/scripts/../configs', '/builds/slave/b2g_m-b18_inari_ntly-000000000/scripts/scripts/../../configs']!
(Assignee)

Comment 14

5 years ago
Inari builds should be getting updates on mozilla-b2g18 and mozilla-b2g18_v1_0_1 now.
On Inari 1.0.1 device;
verified OTA fix:  20130506230205 -> 20130507070205 is successful.
(Assignee)

Comment 16

5 years ago
Created attachment 746714 [details] [diff] [review]
update releng-beta.py config to set publish_channel to nightly
Attachment #746714 - Flags: review?(nthomas)
(Assignee)

Comment 17

5 years ago
Created attachment 746716 [details] [diff] [review]
enable updates for leo, hamachi
Attachment #746716 - Flags: review?(nthomas)
Comment on attachment 746716 [details] [diff] [review]
enable updates for leo, hamachi

This only turns on hamachi updates for 1.0.1, is that expected ? In b2g_config.py, leo is included in the BRANCHES definition for mozilla-b2g18_v1_0_1 but a loop deletes it later.
Attachment #746716 - Flags: review?(nthomas) → review+
Poorly phrased comment there - On 1.0.1, this only turns on updates for hamachi. Does both for m-b2g18.
Comment on attachment 746714 [details] [diff] [review]
update releng-beta.py config to set publish_channel to nightly

It looks like the xml fo;es will have .../beta/... for the mar url, via base_url and nightly_update_channel. r+ if wsgi means that still works ok when published to /nightly/.
Attachment #746714 - Flags: review?(nthomas) → review+

Comment 21

5 years ago
Erm, BTW, if the channel names we end up here are in any way substantially different from what we had before, we need to clear up with the Socorro team on how we can make crash-stats with those. Their system is extremely closely tied to our usual scheme of channel names, and any substantial difference will break them with multiple weeks or months of work needed to get anything to work with them.

Updated

5 years ago
Depends on: 869905

Comment 22

5 years ago
As a side note, we currently have set up the rule that whatever releases are being put in the wild for Firefox OS should have "release-<vendor>" set as release channels so that we can do something useful with crash data (I wonder how well this is communicated atm though). If this changes that assumption, we need to communicate this.
(Assignee)

Updated

5 years ago
Attachment #746716 - Flags: checked-in+
(Assignee)

Comment 23

5 years ago
leo/hamachi configs deployed in production
(Assignee)

Comment 24

5 years ago
(In reply to Nick Thomas [:nthomas] from comment #20)
> Comment on attachment 746714 [details] [diff] [review]
> update releng-beta.py config to set publish_channel to nightly
> 
> It looks like the xml fo;es will have .../beta/... for the mar url, via
> base_url and nightly_update_channel. r+ if wsgi means that still works ok
> when published to /nightly/.

so I think the mar will still exist at the original location, so this should still work...or am I missing something?
(Assignee)

Updated

5 years ago
Attachment #746714 - Flags: checked-in+

Comment 25

5 years ago
This issue is resolved for:
Unagi v1.1.0 Mozilla RIL
Build ID: 20130508070204-> Build ID: 20130509070205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/84f4c17f1605
Gaia: 4e7d63a83508caa391c4db164c3f68422d9ca5b6
and
Inari v1.0.1 Mozilla RIL
Build ID: 20130508070205 -> Build ID: 20130509070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/b0b2b5cfdc5b
Gaia: 30ad443fbe5363a7381c19c6bf9d6ca49228fb8b
Product: mozilla.org → Release Engineering

Comment 26

4 years ago
I think this was done long ago...
Closing.  Please reopen if there's something left to do.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.