Download manager should open in tab (download manager and main window).

UNCONFIRMED
Unassigned

Status

()

Toolkit
Downloads API
--
enhancement
UNCONFIRMED
5 years ago
5 years ago

People

(Reporter: t8av, Unassigned)

Tracking

20 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

I was downloading a file, while two windows are minimized in the task bar of windows7:
1. Firefox (main window).
2. The download manager.

I was trying to open (maximize) the download manager.



Actual results:

Windows 7 shows indication of the download progress on the main Firefox window in the task bar, so I got confused and clicked the main Firefox window instead of the download manager window. 

This confusion happened to me many times.



Expected results:

There are few possible solutions to this problem:

1. Download progress indication should be shown on the minimized download manager window rather than the main Firefox window.

2. The download manager should exist in a tab, and not in a separate window.
See: https://bugzilla.mozilla.org/show_bug.cgi?id=155596
       https://bugzilla.mozilla.org/show_bug.cgi?id=861498
Severity: normal → enhancement

Comment 1

5 years ago
Indeed it's an issue, I am able to reproduce the bug on my Windows7. The second solution you gave, its easy to implement(if i got you right in the first place)
(Reporter)

Comment 2

5 years ago
I did not make a survey, but I feel that 95% of the users would prefer a download manager to exist in a tab rather than in a desperate window, so I wander why wasn't it implemented yet???

I heard there are ADD-ONS to do that but a built-in tabbed download manager is much better. I will dare to use only the second kind.

Comment 3

5 years ago
I just want to confirm if I got you right. Just open private window in ff, and open the download manager there. I guess it should open in the same window in a new tab.
(Reporter)

Comment 4

5 years ago
(In reply to Aish from comment #3)
> I just want to confirm if I got you right. Just open private window in ff,
> and open the download manager there. I guess it should open in the same
> window in a new tab.

What do you mean by private window?
See bugs:
https://bugzilla.mozilla.org/show_bug.cgi?id=234397
https://bugzilla.mozilla.org/show_bug.cgi?id=697359

Comment 5

5 years ago
No, i got that, but this thing is already implemented in private window. So I just copied that code in the main window code and it worked. The download manager is now opening in a tab in same window
(Reporter)

Comment 6

5 years ago
Thanks, so nice of you to implement a feature that so many people need.

In which Firefox version will I be able to see the download manager in a tab?

Comment 7

5 years ago
I am currently working on a nightly build, and thats 23.0
(Reporter)

Comment 8

5 years ago
Good luck with the nightly build.
(Reporter)

Comment 9

5 years ago
Aish,

1. Please don't forget to cancel the "Display the progress of ongoing downloads" arrow in the right side of the upper panel. This button will become redundant after the change.

2. The download manger should, of course, be in a pinned tab.

3. I which Firefox version will I be able to see the change?
Aish are you working on this by yourself? Are you tracking it in another bug?

In bug 234397 seems that this issue has already been discussed and resolved as WONTFIX
Component: Untriaged → Download Manager
Flags: needinfo?(as.asafeather)
OS: Windows 7 → All
Product: Firefox → Toolkit
Summary: Download progress indication causes confusion between the two windows (download manager and main window). → Download manager should open in tab (download manager and main window).

Comment 11

5 years ago
(In reply to Tiziana Sellitto [:tiziana] from comment #10)
> Aish are you working on this by yourself? Are you tracking it in another bug?
> 
> In bug 234397 seems that this issue has already been discussed and resolved
> as WONTFIX

I just tried to solve this, making the inbuilt download manager to open in a new tab. For that i just modified some code, as I said before. I am not sure if its correct to do this, whether it would lead to any problems or not. I need some guidance to work on this.
Flags: needinfo?(as.asafeather)
what about just opening the about:downloads page?
(Reporter)

Comment 13

5 years ago
1. So far, about:downloads works fine for me.

2. The about:downloads tab should always be a pinned tab.

3. An icon is needed for the about:downloads tab, to distinguish it from other tabs. If it is a pinned tab, you cannot read the text, only see an icon.

4. A quick access is needed to the about:downloads tab. Something like Tools->Download tab.

5. See https://bugzilla.mozilla.org/show_bug.cgi?id=870659.
about:downloads so far is not intended for primary UI, it's an interim solution just for private browsing, and has never been intended to become the de-facto download manager. that's why it doesn't do all of the things you pointed out, you can easily do the pinning by yourself, bug 842354 is for the favicons. Btw, don't expect it to be accessible from anywhere any time soon, there's no such plan currently, an add-on could easily do that, too.
You need to log in before you can comment on or make changes to this bug.