Closed Bug 861525 Opened 7 years ago Closed 7 years ago

Work - With certain video cards/drivers, multiple elements (including text and the "back/addtab overlay") render as black rectangles

Categories

(Core :: Graphics, defect, P1)

x86
Windows 8.1
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: timfelgentreff, Unassigned)

References

Details

(Whiteboard: feature=work)

Attachments

(6 files)

User Agent: Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130412 Firefox/23.0
Build ID: 20130412030828

Steps to reproduce:

Start Firefox Metro on a Windows 8 machine with a DirectX 9.3 capable graphics card.


Actual results:

Some text appears rendered as black rectangles (the rectangle color is actually the color the text has - so if the text is supposed to be green, the rectangle will be green). Moving the mouse or scrolling around sometimes shows text, and sometimes makes existing text dissapear in a black rectangle.


Expected results:

Text should be readable.
OS: All → Windows 8 Metro
Hardware: All → x86
Can you dump your about:support in here? This looks like a rendering bug associated with a specific graphic card / driver.
Depends on: 858144
Blocks: 858144
No longer depends on: 858144
No longer blocks: 858144
Depends on: 858144
Attached file about:support output
This may go away once OMTC lands.
Attached file about:support page
I have similar porblems with my Samsung Ativ 500T. 


Operating System
    Windows 8 (32-bit)
CPU/ Processor
    Intel® Atom™ Processor Z2760
Display
    1366 x 768 Screen Resolution 
Graphics
    Intel® SGX545 Graphics Media Accelerator
I have similar porblems with my asus vivo tab smart.


Operating System
    Windows 8 (32-bit)
CPU/ Processor
    Intel® Atom™ Processor Z2760
Display
    1366 x 768 Screen Resolution 
Graphics
    Intel® Graphics Media Accelerator
About:config
{
  "application": {
    "name": "Firefox",
    "version": "23.0a1",
    "userAgent": "Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130421 Firefox/23.0",
    "supportURL": "http://support.mozilla.org/1/firefox/23.0a1/WINNT/en-US/"
  },
  "modifiedPreferences": {
    "browser.cache.disk.capacity": 358400,
    "browser.cache.disk.smart_size.first_run": false,
    "browser.cache.disk.smart_size.use_old_max": false,
    "browser.cache.disk.smart_size_cached_value": 358400,
    "browser.places.smartBookmarksVersion": 4,
    "browser.startup.homepage_override.mstone": "23.0a1",
    "browser.startup.homepage_override.buildID": "20130421031002",
    "dom.w3c_touch_events.expose": true,
    "extensions.lastAppVersion": "23.0a1",
    "gfx.direct3d.checkDX10": false,
    "network.cookie.prefsMigrated": true,
    "places.history.expiration.transient_current_max_pages": 51477,
    "places.database.lastMaintenance": 1366567088,
    "plugin.disable_full_page_plugin_for_types": "application/pdf",
    "privacy.sanitize.migrateFx3Prefs": true,
    "storage.vacuum.last.places.sqlite": 1366561460,
    "storage.vacuum.last.index": 0
  },
  "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 1,
    "windowLayerManagerType": "Direct3D 9",
    "adapterDescription": "Intel(R) Graphics Media Accelerator",
    "adapterVendorID": "0x8086",
    "adapterDeviceID": "0x08cf",
    "adapterRAM": "0",
    "adapterDrivers": "igdumd32",
    "driverVersion": "9.14.3.1099",
    "driverDate": "10-24-2012",
    "adapterDescription2": "",
    "adapterVendorID2": "",
    "adapterDeviceID2": "",
    "adapterRAM2": "",
    "adapterDrivers2": "",
    "driverVersion2": "",
    "driverDate2": "",
    "isGPU2Active": false,
    "direct2DEnabled": false,
    "directWriteEnabled": false,
    "directWriteVersion": "6.2.9200.16433",
    "direct2DEnabledMessage": [
      "blockedDriver"
    ],
    "webglRenderer": "Google Inc. -- ANGLE (Intel(R) Graphics Media Accelerator)",
    "info": {
      "AzureCanvasBackend": "skia",
      "AzureFallbackCanvasBackend": "cairo",
      "AzureContentBackend": "none"
    }
  },
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": true,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.9.6",
      "version": "4.9.6"
    },
    "NSS": {
      "minVersion": "3.15 Basic ECCBeta",
      "version": "3.15 Basic ECCBeta"
    },
    "NSSUTIL": {
      "minVersion": "3.15 Beta",
      "version": "3.15 Beta"
    },
    "NSSSSL": {
      "minVersion": "3.15 Basic ECCBeta",
      "version": "3.15 Basic ECCBeta"
    },
    "NSSSMIME": {
      "minVersion": "3.15 Basic ECCBeta",
      "version": "3.15 Basic ECCBeta"
    }
  },
  "userJS": {
    "exists": false
  },
  "extensions": [
    {
      "name": "Feedback",
      "version": "1.2.2",
      "isActive": true,
      "id": "testpilot@labs.mozilla.com"
    }
  ]
}
screen shot in attahcment.
Duplicate of this bug: 864157
This is a problem for (most? all?) Windows 8 tablets with the Atom Z2760 (Clovertrail) and Intel GMA 3600 (SGX545) and the driver version 9.14.3.1099

We need to solve this. This is going to be a very large portion of early Firefox Metro users.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Text renders as black rectangle → Text renders as black rectangle - Intel GMA 3600 (SGX545) with driver 9.14.3.1099
Component: General → Graphics: Text
Product: Firefox for Metro → Core
I have the same problem since this bug appeared: https://bugzilla.mozilla.org/show_bug.cgi?id=861549
Earlier builds do not have this problem.
Summary: Text renders as black rectangle - Intel GMA 3600 (SGX545) with driver 9.14.3.1099 → Text renders as black rectangle - Intel GMA 3600 (SGX545) with driver 9.14.3.1102
Duplicate of this bug: 861549
Summary: Text renders as black rectangle - Intel GMA 3600 (SGX545) with driver 9.14.3.1102 → With certain video cards/drivers, multiple elements (including text and the "back/addtab overlay") render as black rectangles
Duplicate of this bug: 868957
Duplicate bug 868957 || Waiting for it to fix.

  Application Basics

        Name
        MetroFirefox

        Version
        23.0a1

        User Agent
        Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130503 Firefox/23.0

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

  Important Modified Preferences

      Name

      Value

        browser.cache.disk.capacity
        358400

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size.use_old_max
        false

        browser.cache.disk.smart_size_cached_value
        358400

        browser.startup.homepage_override.mstone

        extensions.lastAppVersion
        23.0a1

        gfx.direct3d.last_used_feature_level_idx
        2

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        46956

        plugin.disable_full_page_plugin_for_types
        application/pdf

        privacy.donottrackheader.enabled
        true

  Graphics

        Adapter Description
        NVIDIA GeForce 7025 / NVIDIA nForce 630a

        Adapter Drivers
        nvd3dum

        Adapter RAM
        256

        Device ID
        0x03d6

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.2.9200.16384)

        Driver Date
        3-15-2010

        Driver Version
        8.17.11.9713

        GPU #2 Active
        false

        GPU Accelerated Windows
        1/1 Direct3D 10

        Vendor ID
        0x10de

        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce 7025 / NVIDIA nForce 630a)

        AzureCanvasBackend
        direct2d

        AzureContentBackend
        direct2d

        AzureFallbackCanvasBackend
        cairo

  JavaScript

        Incremental GC
        true

  Accessibility

        Activated
        true

        Prevent Accessibility
        0

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.10 Beta
        4.10 Beta

        NSS
        3.15 Basic ECCBeta
        3.15 Basic ECCBeta

        NSSSMIME
        3.15 Basic ECCBeta
        3.15 Basic ECCBeta

        NSSSSL
        3.15 Basic ECCBeta
        3.15 Basic ECCBeta

        NSSUTIL
        3.15 Beta
        3.15 Beta
Same issue here. ASUS VivoTab, just acquired yesterday. Driver Version a little newer (9.14.3.1117).

A couple more things:
- The text usually renders OK at first, before being quickly replaced by the black bar.
- If I force Direct2D on in the desktop version, I get black bars in the interface there too.
- As far as I can tell, there's never any black bars in the content, just the interface.
Waiting on implementation of OMTC.
Depends on: 849261
Whiteboard: [triaged]
Blocks: metrov1defect&change
No longer blocks: metrov1triage
Priority: -- → P1
Summary: With certain video cards/drivers, multiple elements (including text and the "back/addtab overlay") render as black rectangles → Defect - With certain video cards/drivers, multiple elements (including text and the "back/addtab overlay") render as black rectangles
Whiteboard: [triaged] → [triaged] feature=defect
Whiteboard: [triaged] feature=defect → [triaged][waiting on omtc] feature=defect
Duplicate of this bug: 878585
Whiteboard: [triaged][waiting on omtc] feature=defect → [triaged][waiting on omtc] feature=defect c=tbd u=tbd p=0
Whiteboard: [triaged][waiting on omtc] feature=defect c=tbd u=tbd p=0 → [triaged][waiting on omtc] feature=defect c=content_features u=tbd p=0
Blocks: 870390
Whiteboard: [triaged][waiting on omtc] feature=defect c=content_features u=tbd p=0 → [triaged][waiting on omtc] feature=defect c= u=tbd p=0
No longer blocks: metrov1defect&change
Summary: Defect - With certain video cards/drivers, multiple elements (including text and the "back/addtab overlay") render as black rectangles → Work - With certain video cards/drivers, multiple elements (including text and the "back/addtab overlay") render as black rectangles
Whiteboard: [triaged][waiting on omtc] feature=defect c= u=tbd p=0 → [triaged][waiting on omtc] feature=work
In today's Nightly build we've turned on OMTC and disabled forced D2d backend. So if you're seeing rendering problems after updating please try the following:

1) go to about:config and add the user pref 'gfx.direct2d.disabled' and set it to true.
2) restart the browser
3) test to see if you still see the issue.

If so, please confirm step #1, and post the graphics section of your about:support here.
Component: Graphics: Text → Graphics
Whiteboard: [triaged][waiting on omtc] feature=work → feature=work
oh, oops, nightly builds haven't built yet - 

https://tbpl.mozilla.org/?showall=0&rev=b8a80bf3f9da

Hopefully they'll be up in a few hours.
For me it seems to work fine.
(In reply to wim.lingier from comment #22)
> For me it seems to work fine.

Great, thanks for posting back!
Please reopen if you're still seeing this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 903868
Still have this bug in the latest version of Nightly on my ASUS VivoTab Smart ME400C

 "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 1,
    "windowLayerManagerType": "Direct3D 9",
    "windowLayerManagerRemote": false,
    "adapterDescription": "Intel(R) Graphics Media Accelerator",
    "adapterVendorID": "0x8086",
    "adapterDeviceID": "0x08cf",
    "adapterRAM": "0",
    "adapterDrivers": "igdumd32",
    "driverVersion": "9.14.3.1099",
    "driverDate": "10-24-2012",
    "adapterDescription2": "",
    "adapterVendorID2": "",
    "adapterDeviceID2": "",
    "adapterRAM2": "",
    "adapterDrivers2": "",
    "driverVersion2": "",
    "driverDate2": "",
    "isGPU2Active": false,
    "direct2DEnabled": false,
    "directWriteEnabled": false,
    "directWriteVersion": "6.2.9200.16384",
    "direct2DEnabledMessage": [
      "blockedDriver"
    ],
    "webglRenderer": "Google Inc. -- ANGLE (Intel(R) Graphics Media Accelerator Direct3D9Ex vs_3_0 ps_3_0)",
    "info": {
      "AzureCanvasBackend": "skia",
      "AzureSkiaAccelerated": 0,
      "AzureFallbackCanvasBackend": "cairo",
      "AzureContentBackend": "cairo"
    }
  }
Duplicate of this bug: 926211
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.