Black bar across whole page

RESOLVED DUPLICATE of bug 861525

Status

--
blocker
RESOLVED DUPLICATE of bug 861525
6 years ago
5 years ago

People

(Reporter: Em-a-il, Unassigned)

Tracking

Trunk
All
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 737175 [details]
Screenshot.png

User Agent: Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130413 Firefox/23.0
Build ID: 20130413030927

Steps to reproduce:

Open a website and clicked a link in it.


Actual results:

The overlay back and overlay plus button appears but there is a black bar across the whole page. (See image)
When I hover one of these buttons the black bar disappears.


Expected results:

The overlay back and plus button should appear without that black bar
(Reporter)

Updated

6 years ago
OS: All → Windows 8 Metro
Hardware: All → x86
Blocks: 841214
I'd suspect a hardware acceleration problem. If you type 'about:support' into the address bar in Metro Firefox and hit enter, can you copy/paste the "Graphics" section of that page into this bug report?
(Reporter)

Comment 2

6 years ago
Sure I can:

Graphics
Adapter Description	ATI MOBILITY FireGL V5200
Adapter Drivers	atiumdag atiumdva atitmmxx
Adapter RAM	Unknown
ClearType Parameters	Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
Device ID	0x71c4
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16433)
Driver Date	6-21-2007
Driver Version	8.383.1.1000
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 10
Vendor ID	0x1002
WebGL Renderer	Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer.
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
(Reporter)

Comment 3

6 years ago
I looked for the graphics driver update but there's no newer version available.

Updated

6 years ago
Depends on: 858144
> Graphics
> Adapter Description	ATI MOBILITY FireGL V5200
> Driver Date	6-21-2007
> Driver Version	8.383.1.1000

http://mxr.mozilla.org/mozilla-central/source/widget/windows/GfxInfo.cpp#770

Blocked on desktop, ver < 8,741,0,0.

Updated

6 years ago
Blocks: 858144
No longer depends on: 858144

Updated

6 years ago
No longer blocks: 858144
Depends on: 858144

Comment 5

6 years ago
I have the same problem. I also have the problem 861525 (I use asus vivo tab smart).

Comment 6

6 years ago
For those having this problem I downgraded to 

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-09-03-08-55-mozilla-central/firefox-23.0a1.en-US.win32.installer.exe 

build of nightly and no longer have the issue. Something in the graphics is causing the URL and overlays to have black text and background. If you pull the screen up or down to see the settings and new window screen, press the down arrow, you can see how the plus and arrow should look when working correctly.
(Reporter)

Updated

6 years ago
Severity: normal → blocker
Ditto for me on x64 windows 8 under vmware:

Adapter Description	VMware SVGA 3D (Microsoft Corporation - WDDM)
Adapter Drivers	vm3dum64 vm3dum vm3dgl64 vm3dgl
Adapter RAM	128
Device ID	0x0405
Direct2D Enabled	Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled	false (6.2.9200.16384)
Driver Date	11-11-2011
Driver Version	7.14.1.1134
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic Blocked for your graphics card because of unresolved driver issues.
Vendor ID	0x15ad
WebGL Renderer	Blocked for your graphics card because of unresolved driver issues.
AzureCanvasBackend	skia
AzureContentBackend	none
AzureFallbackCanvasBackend	cairo

I don't see that specifically in GfxInfo.cpp, but given it is listed as "blocked" it's almost certainly the same problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
This is surely a dupe of bug 861525, right?
(In reply to Asa Dotzler [:asa] from comment #8)
> This is surely a dupe of bug 861525, right?

Possibly - I see both the text rendered incorrectly *and* the black bar in the attachment on this bug.  However, the screenshots in bug 861525 don't appear to show the black bar while the screenshot in this bug doesn't seem to show the text rendering problem.
(In reply to Mark Hammond (:markh) from comment #9)
> (In reply to Asa Dotzler [:asa] from comment #8)
> > This is surely a dupe of bug 861525, right?
> 
> Possibly - I see both the text rendered incorrectly *and* the black bar in
> the attachment on this bug.  However, the screenshots in bug 861525 don't
> appear to show the black bar while the screenshot in this bug doesn't seem
> to show the text rendering problem.

My guess is that those screenshots were taken before the overlay landed (the overlay is what renders incorrectly as the black bar across the middle of the screen).

I would expect that whatever patch fixes bug 861525 will also fix this bug.  Perhaps we should consolidate.
(Reporter)

Comment 11

6 years ago
Yes, I also think that bug 861525 will fix this also.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861525

Updated

6 years ago
No longer blocks: 841214
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.