[tara]modify tara.xml for gonk upgrade

RESOLVED FIXED

Status

Firefox OS
General
--
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: James Zhang (Spreadtrum), Assigned: James Zhang (Spreadtrum))

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

5 years ago
tara gonk upgrade, need to add some repository.
add external/e2fsprogs and external/llvm, the same as otoro.xml.
add external/iproute2, to fix bug ,data call can't connect.
add external/gcc-demangle, to fix compiler error.
remove external/wpa_supplicant_6, it's unused.
(Assignee)

Comment 1

5 years ago
Created attachment 737224 [details] [diff] [review]
tara.xml.patch

Hi Michael,
   Can you help to apply this patch for tara gonk upgrade. Thanks!

James
(Assignee)

Comment 2

5 years ago
change Importance
Severity: major → blocker
(Assignee)

Comment 3

5 years ago
Created attachment 737230 [details] [diff] [review]
build.patch

We opensource u-boot and linux kernel, and we can configure different uboot, such as 128M RAM and 256M of RAM.
We need use kheader before build, and add u-boot to makefile, otherwise there will be complier errors.
(Assignee)

Comment 4

5 years ago
Created attachment 737231 [details] [diff] [review]
echo kheader to .config and use it before build

Comment 5

5 years ago
Comment on attachment 737224 [details] [diff] [review]
tara.xml.patch

Review of attachment 737224 [details] [diff] [review]:
-----------------------------------------------------------------

Can you submit a pull request for this?

::: tara.xml
@@ +74,4 @@
>    <project name="platform/external/webp" path="external/webp" />
>    <project name="platform/external/webrtc" path="external/webrtc" />
>    <project name="platform/external/wpa_supplicant" path="external/wpa_supplicant" />
> +  <!-- project name="platform/external/wpa_supplicant_6" path="external/wpa_supplicant_6" / -->

Just remove this line entirely.
Attachment #737224 - Flags: review+

Comment 6

5 years ago
Comment on attachment 737231 [details] [diff] [review]
echo kheader to .config and use it before build

Review of attachment 737231 [details] [diff] [review]:
-----------------------------------------------------------------

Where does the kheader command come from? This looks like it's working around a bug in your distro. Those sort of fixes do not belong here.
(Assignee)

Comment 7

5 years ago
Can you help me how to pull request? 
I can't push the commit to mozilla master branch.

Use command as below.
git push origin HEAD:master
fatal: remote error: 
  You can't push to git://github.com/mozilla-b2g/b2g-manifest.git
  Use git@github.com:mozilla-b2g/b2g-manifest.git

Use command as below.
git remote add github git@github.com:mozilla-b2g/b2g-manifest.git
git push origin HEAD:master
ssh: connect to host github.com port 22: Connection timed out
fatal: The remote end hung up unexpectedly


(In reply to Michael Wu [:mwu] from comment #5)
> Comment on attachment 737224 [details] [diff] [review]
> tara.xml.patch
> 
> Review of attachment 737224 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Can you submit a pull request for this?
> 
> ::: tara.xml
> @@ +74,4 @@
> >    <project name="platform/external/webp" path="external/webp" />
> >    <project name="platform/external/webrtc" path="external/webrtc" />
> >    <project name="platform/external/wpa_supplicant" path="external/wpa_supplicant" />
> > +  <!-- project name="platform/external/wpa_supplicant_6" path="external/wpa_supplicant_6" / -->
> 
> Just remove this line entirely.
(Assignee)

Comment 8

5 years ago
Done.

(In reply to Michael Wu [:mwu] from comment #5)
> Comment on attachment 737224 [details] [diff] [review]
> tara.xml.patch
> 
> Review of attachment 737224 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Can you submit a pull request for this?
> 
> ::: tara.xml
> @@ +74,4 @@
> >    <project name="platform/external/webp" path="external/webp" />
> >    <project name="platform/external/webrtc" path="external/webrtc" />
> >    <project name="platform/external/wpa_supplicant" path="external/wpa_supplicant" />
> > +  <!-- project name="platform/external/wpa_supplicant_6" path="external/wpa_supplicant_6" / -->
> 
> Just remove this line entirely.
(Assignee)

Comment 9

5 years ago
(In reply to Michael Wu [:mwu] from comment #6)
> Comment on attachment 737231 [details] [diff] [review]
> echo kheader to .config and use it before build
> 
> Review of attachment 737231 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Where does the kheader command come from? This looks like it's working
> around a bug in your distro. Those sort of fixes do not belong here.

We need install kernel head file first to avoid frameworks complier errors, sprd frameworks depended on some kernel head file.
You can find it in device/sprd/common/vendorsetup.sh.

function kheader()
{
	T=$(gettop)
	if [ ! "$T" ]; then
		echo "Couldn't locate the top of the tree.  Try setting TOP."
		return
	fi
	mkdir -p $OUT/obj/KERNEL
	make -C $T/kernel O=$OUT/obj/KERNEL ARCH=arm CROSS_COMPILE=arm-eabi- headers_install
}
(Assignee)

Comment 10

5 years ago
Hi Michael,

   Maybe we need not kheader patch now, the latest master branch has no build errors. Thanks.

Comment 11

5 years ago
Manifest update merged - thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Assignee: nobody → james.zhang

Comment 12

5 years ago
I just noticed that there's still an issue with u-boot - I'll open a follow up bug to track that.

Updated

5 years ago
Blocks: 864443
You need to log in before you can comment on or make changes to this bug.