crash when reading from news.netscape.com

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: bbaetz, Assigned: Bienvenu)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I'm trying to read internal newsgroups, and I keep crashing. I've removed and
readded the newsgroup, and the server, and manually deleted the files from my
profile dir. It doesn't help.

I'm seeing all articles appearing twice, but only clicking on the first one
actually does anything. Since I subscribed to these groups, I've been crashing
all the time, with the following stack:

#0  0x402e0c24 in __pthread_mutex_lock (mutex=0x406c7310) at mutex.c:96
#1  0x4061dd4d in __libc_free (mem=0x92e8c38) at malloc.c:3052
#2  0x406f5136 in __builtin_delete (ptr=0x92e8c38)
   from /usr/lib/libstdc++-libc6.2-2.so.3
#3  0x43c4bd17 in orkinHeap::Free (this=0x8dcd170, mev=0x90a75e8, 
    inBlock=0x92e8c38)
    at /home/bbaetz_local/src/mozilla/db/mork/src/orkinHeap.cpp:148
#4  0x43c5ee2b in morkNode::ZapOld (this=0x92e8c38, ev=0x8dc2bc8, 
    ioHeap=0x8dcd170)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:194
#5  0x43c5fa55 in morkNode::CutWeakRef (this=0x92e8c38, ev=0x8dc2bc8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:609
#6  0x43c5f8a4 in morkNode::CutStrongRef (this=0x92e8c38, ev=0x8dc2bc8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:552
#7  0x43c5f5b4 in morkNode::SlotStrongNode (me=0x0, ev=0x8dc2bc8, 
    ioSlot=0x9089ba8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:445
#8  0x43c7e983 in morkObject::SlotStrongObject (me=0x0, ev=0x8dc2bc8, 
    ioSlot=0x9089ba8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkObject.h:100
#9  0x43c5c1ed in morkHandle::CloseHandle (this=0x9089b88, ev=0x8dc2bc8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkHandle.cpp:117
#10 0x43c5bf63 in morkHandle::CloseMorkNode (this=0x9089b88, ev=0x8dc2bc8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkHandle.cpp:58
#11 0x43c5f81b in morkNode::cut_use_count (this=0x9089b88, ev=0x8dc2bc8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:530
#12 0x43c5f88d in morkNode::CutStrongRef (this=0x9089b88, ev=0x8dc2bc8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:551
#13 0x43c5ca60 in morkHandle::Handle_CutStrongRef (this=0x9089b88, 
    mev=0x90a75e8)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkHandle.cpp:394
#14 0x43c532a2 in orkinTableRowCursor::Release (this=0x9089b88)
    at /home/bbaetz_local/src/mozilla/db/mork/src/orkinTableRowCursor.cpp:153
#15 0x420f0555 in nsMsgThread::GetChildHdrAt (this=0x90cfb88, aIndex=0, 
    result=0x93cdd58)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:456
#16 0x420f1cbc in nsMsgThread::GetChildHdrForKey (this=0x90cfb88, 
    desiredKey=66327, result=0x93cdd58, resultIndex=0x0)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:996
#17 0x420f183e in nsMsgThread::GetRootHdr (this=0x90cfb88, resultIndex=0x0, 
    result=0x93cdd58)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:895
#18 0x420f0a5a in nsMsgThreadEnumerator::nsMsgThreadEnumerator (
    this=0x93cdd48, thread=0x90cfb88, startKey=66327, filter=0, closure=0x0)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:616
#19 0x420f15e7 in nsMsgThread::EnumerateMessages (this=0x90cfb88, 
   parentKey=66327, result=0xbf8003cc)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:848

etc.

The unreadable messages get added to the "unread message" count, and I have to
mark all as read to clear that, since I can't click on the green dots.

CVS from the morning + the beta bits, + cvs from last night all show this. I
have no problems reading from news.mozilla.org, or secnews.netscape.com.
(Reporter)

Updated

18 years ago
Keywords: crash
(Reporter)

Comment 1

18 years ago
I'm getting lots of assertions (this from when I was reading mail, not the ng.
Maybe biff set it off?)

###!!! ASSERTION: CreateNewHdr didn't fail, but it returned a null newMsgHdr:
'newMsgHdr', file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPNewsgroupList.cpp, line 485
###!!! Break: at file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPNewsgroupList.cpp, line 485
###!!! ASSERTION: failed to process the XOVERLINE: 'NS_SUCCEEDED(rv)', file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 3552
###!!! Break: at file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 3552
###!!! ASSERTION: CreateNewHdr didn't fail, but it returned a null newMsgHdr:
'newMsgHdr', file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPNewsgroupList.cpp, line 485
###!!! Break: at file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPNewsgroupList.cpp, line 485
###!!! ASSERTION: failed to process the XOVERLINE: 'NS_SUCCEEDED(rv)', file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 3552
###!!! Break: at file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 3552
###!!! ASSERTION: CreateNewHdr didn't fail, but it returned a null newMsgHdr:
'newMsgHdr', file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPNewsgroupList.cpp, line 485
###!!! Break: at file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPNewsgroupList.cpp, line 485
###!!! ASSERTION: failed to process the XOVERLINE: 'NS_SUCCEEDED(rv)', file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 3552
###!!! Break: at file
/home/bbaetz_local/src/mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 3552
###!!! ASSERTION: db must be corrupt: 'PR_FALSE', file
/home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 1007
###!!! Break: at file
/home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 1007
###!!! ASSERTION: db must be corrupt: 'PR_FALSE', file
/home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 1007
###!!! Break: at file
/home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 1007

and I have deleted the db, and that didn't help.
I'm seeing no problems with RedHat 7.1 and comm opt build 2001-06-15-08, do you
see this in opt as well, or just debug?  (I do see the double messages, but I'm
pretty sure that's a server issue, not us).  I'll check with 4.x
QA Contact: esther → stephend
adding seth.  david is on vacation.
(Reporter)

Comment 4

18 years ago
self-build opt and debug builds, as well as the installer.

Do you have biff turned on for that server?

lynx doesn't see the double messages, though. So its not totally a server issue.
If its not related to teh crash, then I'll file it as a separate bug.

I also don't see double messages on other groups on that server (non mcom.* ones)

Comment 5

18 years ago
Bradley, do you see this on Windows or Mac?
bradley, how many messages are you downloading?

on win98, I downloaded 500 and it works for me on some of the
news://news.netscape.com/mcom.beta.* newsgroups, and it worked for me.

I'll try my linux debug build tomorrow.
(Reporter)

Comment 7

18 years ago
I haven't tried (I'll try tomorrow)

I unsubscribed from the group, and the problems went away. I'll try
resubscribing tomorrow, and see.

stephend was seeing the double, unclickable, posts as well as me, which weren't
shown using lynx to read the groups.

Is anyone else seeing those?
(Reporter)

Comment 8

18 years ago
Well, on windows via SERA, using 2001061404 comm build, I'm not crashing. I'm
not seeing the double posts either, even on messages which did show twice
earlier. Maybe it was a news server confiugration problem which is now fixed,
and so doesn't trigger the bug?

What I do get, every so often, just clicking random articles one after the
other, is the error:

newsgroup server responded:Not in a newsgroup

No idea if this is related, but it seems an odd error to me.

I'll try from linux tomorrow, and try an updated build on windows.
I have seen the "double" posts before.

there might be a bug on it, but I think it got marked worksforme as it went away
for the reporter.

question:  are you reading news on that server over SSL?
(Reporter)

Comment 10

18 years ago
...and about 5 minutes before I closed this out as invalid, I crashed again. opt
build, so no backtrace (and I wasn't running under the debugger anyway)

The double posts had vanished (even on posts where they previously showed). Then
they came back, and I crashed.

Anyone want my news database file, or something? Be quick, before it fixes
ittself :)
(Reporter)

Comment 11

18 years ago
And this now happens whenever I load that group, this time with a different
stack trace:

#0  0x43ccd98b in morkNode::CutWeakRef (this=0x907eb30, ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:588
#1  0x43ccd624 in morkNode::SlotWeakNode (me=0x0, ev=0x82654a0, 
    ioSlot=0x9371738)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:466
#2  0x43cee34b in morkTable::SlotWeakTable (me=0x0, ev=0x82654a0, 
    ioSlot=0x9371738)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkTable.h:285
#3  0x43cde265 in morkTableRowCursor::CloseTableRowCursor (this=0x9371710, 
    ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkTableRowCursor.cpp:116
#4  0x43cde0bf in morkTableRowCursor::CloseMorkNode (this=0x9371710, 
    ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkTableRowCursor.cpp:74
#5  0x43ccd81b in morkNode::cut_use_count (this=0x9371710, ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:530
#6  0x43ccd88d in morkNode::CutStrongRef (this=0x9371710, ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:551
#7  0x43ccd5b4 in morkNode::SlotStrongNode (me=0x0, ev=0x82654a0, 
    ioSlot=0x9272b60)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:445
#8  0x43cec983 in morkObject::SlotStrongObject (me=0x0, ev=0x82654a0, 
    ioSlot=0x9272b60)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkObject.h:100
#9  0x43cca1ed in morkHandle::CloseHandle (this=0x9272b40, ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkHandle.cpp:117
#10 0x43cc9f63 in morkHandle::CloseMorkNode (this=0x9272b40, ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkHandle.cpp:58
#11 0x43ccd81b in morkNode::cut_use_count (this=0x9272b40, ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:530
#12 0x43ccd88d in morkNode::CutStrongRef (this=0x9272b40, ev=0x82654a0)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkNode.cpp:551
#13 0x43ccaa60 in morkHandle::Handle_CutStrongRef (this=0x9272b40, 
    mev=0x8265548)
    at /home/bbaetz_local/src/mozilla/db/mork/src/morkHandle.cpp:394
#14 0x43cc12a2 in orkinTableRowCursor::Release (this=0x9272b40)
    at /home/bbaetz_local/src/mozilla/db/mork/src/orkinTableRowCursor.cpp:153
#15 0x44b96555 in nsMsgThread::GetChildHdrAt (this=0x8f8c978, aIndex=0, 
    result=0x955cc20)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:456
#16 0x44b97cbc in nsMsgThread::GetChildHdrForKey (this=0x8f8c978, 
    desiredKey=67245, result=0x955cc20, resultIndex=0x0)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:996
#17 0x44b9783e in nsMsgThread::GetRootHdr (this=0x8f8c978, resultIndex=0x0, 
    result=0x955cc20)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:895
#18 0x44b96a5a in nsMsgThreadEnumerator::nsMsgThreadEnumerator (
    this=0x955cc10, thread=0x8f8c978, startKey=67245, filter=0, closure=0x0)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:616
#19 0x44b975e7 in nsMsgThread::EnumerateMessages (this=0x8f8c978, 
    parentKey=67245, result=0xbf8003ac)
    at /home/bbaetz_local/src/mozilla/mailnews/db/msgdb/src/nsMsgThread.cpp:848
#20 0x43fcb418 in nsMsgDBView::ListIdsInThreadOrder (this=0x82b2210, 
    threadHdr=0x8f8c978, parentKey=67245, level=47592, viewIndex=0xbfffd304, 
    pNumListed=0xbfffd36c)
    at /home/bbaetz_local/src/mozilla/mailnews/base/src/nsMsgDBView.cpp:3159

so something is wrong, but I don't know if the double posts are a symptom or the
cause. Again, only this group.

I've made a backup of the contents of News/ in my profile directory. Let me know
if you want it.

Also, I'm not getting assertions this time.
(Reporter)

Comment 12

18 years ago
Deleting mcom.beta.feedback.browser.msf made everything work again. At least for
now. (I kept a backup, in case someone wants it)
Summary: crash when reading from news.netscape.com [@ orkinHeap::Free] → crash when reading from news.netscape.com
that's a dup of the infamous bug.

stephend, can you dup this?

stephend, did you ever find (or log) a bug on the .msf version update issue?

This Mork bug seems like it's still around and something has unmasked it again
(or we're simply seeing a re-occurance of the original bug 82595).  That bug was
marked verified fixed for new profiles, but the reporter of a new bug 86945 says
it's happening for him on a new profile (it's not for me, however with the same
OS and build #.)  I've only got yesterday's build right now, and I'll try
Bradley's scenario again with it.
Created attachment 39452 [details]
Log file using build 6-19-14, seeing a hang.
Here are some of Navin/my observations:

http://lxr.mozilla.org/seamonkey/source/mailnews/news/src/nsNNTPProtocol.cpp#342
8

3428     PR_LOG(NNTP,PR_LOG_ALWAYS,("Chunk will be (%d-%d)", m_firstArticle, 
m_lastArticle));

Yet below, we're saying the first and last are the same

1024[8054af8]: Next state: NNTP_FIGURE_NEXT_CHUNK
1024[8054af8]: Chunk will be (67283-67283)


skipping down a ways:

http://lxr.mozilla.org/seamonkey/source/mailnews/news/src/nsNNTPProtocol.cpp#338
0

3380       PR_LOG(NNTP,PR_LOG_ALWAYS,("add to known articles:  %d - %d", 
m_firstArticle, m_lastArticle));

And we see the same thing below that was pointed out above:

1024[8054af8]: Next state: NNTP_FIGURE_NEXT_CHUNK
1024[8054af8]: add to known articles:  67283 - 67283

Of course, only Seth/David and others will know for sure.
It should be noted that I tried to download all of the headers, I'm sure that 
has something to do with it.  Should also be noted that if you do try to 
download all of the headers, you will run into lack of header download count 
updates, throbber activity, and general app responsiveness. I saw the throbber 
only update once every 3-5 minutes, and Moz stopped updating the "Downloading X 
of 67231 headers" at # 59720, after which the program hung.  If it turns out 
these are seperate bugs, I'll re-file what I'm seeing as seperate, but I feel 
they might certainly be related.
(Reporter)

Comment 18

18 years ago
It doesn't hang. I downloaded about 3000 headers, IIRC, but I went to have lunch
while I waited (I don't know how long it actually took, but it was > 5 minutes).
Mark all read (even when there were < 5 unread articles) takes ages.

I think that these are other bugs though.

This is a new profile, and I deleted that .msf file earlier in the week (After I
reported this bug), but now the problem has returned. (Yes, I did read the
release notes :-) In fact, I only subscribed to this group after PR1 came out. I
was subscribed to the server before, but I started after that bug was fixed, I
think. So this isn't a dupe of bug 82595.

I have been switching between self-built trunk builds and PR1 (but nothing
ealier) though. Could that be doing it? I've seen the crash on both though.

Given that the two stack traces were different, and the symptoms (always crash
when loading the group vs crash sometimes while reading it (or not, in some
cases)) I'm wondering if these are two separate bugs. Unfortunately, I didn't
keep the .msf file arround from the first time.
Both self-builds and PR1 should have Bienvenu's fix.  So this is still a real
problem (not sure why I'm not seeing it, however).  I will log a new bug on what
I've been seeing, so we can keep this bug to scope.
I've filed bug 87164 about my specific problem.
(Reporter)

Comment 21

18 years ago
Just crashed again, same group. Marking nsdogfood, since this is really, really
annoying. At this rate I'll have to use ns4 to read that group.
Keywords: nsdogfood
update on my side: I'm still not seeing a crash reading postings on the 1st
newsgroup you referenced: mcom.beta.feedback.browser using news.netscape.com as
my server.  And, I've left the newsgroup to collect new messages, something
which used to cause the old bug 82595 crash regarding threads.
(Reporter)

Comment 23

18 years ago
stephend: No idea :( I spent 10 minutes in windows reading it via SERA, and it
didn't crash.

(BTW, sorry if I came off as a bit rude on my last comment. I was just about to
press send on my status report, and my draft copy wasn't saved, so I had to
retype it all)

I still have the open offer to send my .msf file off to anyone who wants.
(Assignee)

Comment 24

18 years ago
could someone who has a newsgroup that opening crashes on please post the .msf
file and the newsgroup+server name for the group. Then I can try to bulletproof
it so we don't crash. Thanks.
(Assignee)

Comment 25

17 years ago
probably same as bug 90215
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Same newsgroup as Lisa, when I verified that her bug was fixed:

See bug 86016 for more info. 

Verified FIXED.

Note: both this bug and bug 88016 are probably DUPs of bug 90215 though.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.