"Request URL" field in the Network Monitor details panel should be selectable/copyable

RESOLVED DUPLICATE of bug 887605

Status

P2
normal
RESOLVED DUPLICATE of bug 887605
6 years ago
5 months ago

People

(Reporter: KWierso, Assigned: vporof)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I'd find it useful to be able to copy the requested URL from a chosen request selected in the Network monitor, either from a context menu item in the list of requests, or from the Headers section off to the side.
(Assignee)

Comment 1

6 years ago
Some overlap here with bug 859052, but let's keep this bug open.
(Assignee)

Updated

6 years ago
Summary: "Request URL" field in Network panel should be selectable/copyable → "Request URL" field in the Network Monitor details panel should be selectable/copyable
(Assignee)

Updated

6 years ago
Priority: -- → P2
(Assignee)

Updated

6 years ago
Duplicate of this bug: 863741
(Assignee)

Updated

6 years ago
See Also: → bug 794152

Comment 3

6 years ago
Can even copy File, Domain, etc.
Can stare at it but not copy it.

Comment 4

6 years ago
Can even->Can't even.
Is there a way I can convince the team to give this higher priority?

For me this is the primary reason to still mainly use the Chrome inspector I often have to look at stuff and then copy things around. This is kind of a deal breaker.

Ideally we can right click on a line in the waterfall and have several options there like Chrome does.
(Assignee)

Comment 6

6 years ago
I'll look into this asap.

Comment 7

6 years ago
"Open in new tab" would also be nice, but yeah, copying to clipboard is critical.
I think ideally there is also an extension point so that we can write addons for the developer tools to do all kinds of cool stuff. For example I would like to implement a 'Copy as CURL' command like Chrome has.
(Assignee)

Comment 9

6 years ago
(In reply to lepbgzr from comment #7)
> "Open in new tab" would also be nice, but yeah, copying to clipboard is
> critical.

That's an amazing idea!

(In reply to Stefan Arentz [:st3fan] from comment #8)
> I think ideally there is also an extension point so that we can write addons
> for the developer tools to do all kinds of cool stuff. For example I would
> like to implement a 'Copy as CURL' command like Chrome has.

That'd be pretty cool, and yes, making it easier for addons to extend is certainly something that needs to be taken care of, but do note that, specifically for cURL, there are plans to support this by default: bug 859059.
(Assignee)

Updated

6 years ago
See Also: → bug 887605
(Assignee)

Updated

6 years ago
Assignee: nobody → vporof
Status: NEW → ASSIGNED
(Assignee)

Comment 10

5 years ago
This was fixed in bug 887605.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 887605

Comment 11

5 years ago
still unable to copy Request URL

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.