Contact search doesn't work (and progress spinner never stops)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: MattN, Unassigned)

Tracking

({b2g-testdriver, regression, unagi})

unspecified
ARM
Gonk (Firefox OS)
b2g-testdriver, regression, unagi

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

STR:
1) Open contacts app
2) Tap in search field
3) Type some text that is in the name of a contact

Expected result:
Contact list is filtered based on the search text

Actual result:
* Search progress spinner spins indefinitely
* No contacts are listed
* No Gecko messages in logcat

I am running v1.1 beta build 20130404070202

Comment 1

5 years ago
By v1.1 you mean branch v1-train?
Flags: needinfo?(mnoorenberghe+bmo)

Updated

5 years ago
blocking-b2g: leo? → leo+

Comment 2

5 years ago
We were able to repro on v1.1.
tracking-b2g18: ? → ---
Flags: needinfo?(mnoorenberghe+bmo)

Comment 3

5 years ago
Not sure if this is from the recent full name search landing or something else.
Flags: needinfo?(jmcf)
Flags: needinfo?(felash)
Keywords: regression
as said on IRC, the full name search was not uplifted to 1.1 yet, but I'll take a look at this bug while uplifting today.
Assignee: nobody → felash
Flags: needinfo?(felash)
Okay, I just saw it was in the Contacts app and not in the Sms app, so I can't say much, and it is absolutely not related to any patch landed in the Sms app.

That said, I don't reproduce this on v1-train, so I suspect this is specific to the contacts that :mattn has... Yay.

Comment 6

5 years ago
Can't reproduce neither
Keywords: qawanted

Updated

5 years ago
QA Contact: isabelrios

Comment 7

5 years ago
I was not able to reproduce this on v1. 
The contacts searched for, showed up.  


Unagi Build ID: 20130417070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d1b2e28b303f
Gaia: 3774a756e70ec322d363b49d29fea43c5b214cff
Keywords: qawanted
This may be caused by bug 861707 but I won't know until I get that fix on v1.1

Comment 9

5 years ago
Hi Alberto, Matthew,

I could not reproduce this on v1-train neither.

I suggested that you might close this bug.
Assignee: felash → nobody

Comment 10

5 years ago
Tested and the contacts searched for are correctly showed up.
BUILD:
unagi-ICS.user.manifest.V1-train.Rel0.4.Sprint8.B-121.Gecko-950b402.Gaia-5cbb19e

Comment 11

5 years ago
Reopen if someone else can reproduce it
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Flags: needinfo?(jmcf)
You need to log in before you can comment on or make changes to this bug.