Loan test slave ubuntu64 to dburns to debug bug 838607

RESOLVED FIXED

Status

Infrastructure & Operations
Buildduty
RESOLVED FIXED
5 years ago
16 days ago

People

(Reporter: automatedtester, Assigned: armenzg)

Tracking

Details

(Whiteboard: [buildduty])

(Reporter)

Description

5 years ago
We have a tricky situation that for clicks on marionette they dont appear to be firing properly on ubuntu64 and its making me sad and mad.

Please can I have a VM for debugging!

Comment 1

5 years ago
Armen, can you get dave burns a EC2 machine to debug this problem on?  We are starting to have other tests fail with the same symptom, so we are worried that the problem spans multiple tests and catching it sooner rather than later would be good.

Thanks!
Flags: needinfo?(armenzg)
I've already attempted to debug this on a VM and was unable to reproduce it, so am thinking we'll have to solve it another way.  Dave, do you still think you want the VM?
Flags: needinfo?(dburns)
(Reporter)

Comment 3

5 years ago
This appears to be an issue that 90% of the time happens on the EC2 boxes according to OF. :JGriffin, did you test it on those VMs or a local VM? 

Locally I cant reproduce so leads me to think there is something unique on the boxes releng have set up
Flags: needinfo?(dburns) → needinfo?(jgriffin)
Yes, I tested it on an Ubuntu64 VM that was loaned to me by rel-eng.  I couldn't repro the issue at all, see https://bugzilla.mozilla.org/show_bug.cgi?id=838607#c159.

I have no explanation why we're seeing it in production but I can't reproduce it locally, even with the exact same environment.

I think in order to fix this problem we'll need to figure out what the Selenium atom for click used to do for us, that we're not doing ourselves.

If you feel the slave would be helpful, I can send you access details to my VM, so that rel-eng doesn't have to generate another for checkout.
Flags: needinfo?(jgriffin)
Flags: needinfo?(armenzg)
Let's take this discussion to bug 838607.  David, if you want access to the VM, let me know.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Sorry, I totally spaced out on this.  The VM I checked out is one of the new linux hardware slaves, the kind that David needs is an ubuntu64 AWS VM.  I couldn't reproduce this problem on the former, but TBPL is using the latter, so he'll still need one of these.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Whiteboard: [buildduty]
ping!  Can dburns get one of these slaves soonish?  The bug it's being used to investigate is one of the top oranges in TBPL. :(

Comment 8

5 years ago
(In reply to Jonathan Griffin (:jgriffin) from comment #7)
> ping!  Can dburns get one of these slaves soonish?  The bug it's being used
> to investigate is one of the top oranges in TBPL. :(

Best bet is to hassle in #releng - I'll do that for you now.
Ooops, sorry. I'll send the credentials in ~15 mins.
Depends on: 867254
tst-dburns-ubuntu64-001/10.134.57.19 loaned, credentials sent.

Please reassign the bug to nobody once you are done with the VM.
Assignee: nobody → dburns
(Reporter)

Comment 11

5 years ago
tagging jgriffin in on this one...
Assignee: dburns → jgriffin
Unassigning; this slave can be terminated.
Assignee: jgriffin → nobody
Taking to terminate.
Assignee: nobody → armenzg
And revoke BuildVPN access.
(In reply to Rail Aliiev [:rail] from comment #10)
> tst-dburns-ubuntu64-001/10.134.57.19 loaned, credentials sent.
> 
Terminated.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(mass move of loan bugs to new releng component, filter on CallekAug2013LoanerMove )
Component: Release Engineering → Release Engineering: Loan Requests
Product: mozilla.org → Release Engineering
Component: Loan Requests → Buildduty
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.