If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Using file picker to open file doesn't open file...

VERIFIED DUPLICATE of bug 9582

Status

SeaMonkey
UI Design
P2
minor
VERIFIED DUPLICATE of bug 9582
19 years ago
13 years ago

People

(Reporter: jay, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Although typing in a URL from the File|Open dialog works fine, if i click on the
 select file button and try to open a local file (i tried to open a bookmark
file) the file doesn't load, the default homepage loads instead
(www.mozillazine.com).

Steps:
1. Click File|Open to get to Open Location dialog
2. Click on Select File... button to get to Open File dialog
3. Choose any file and click on Open button
4. The file should be opened in the window (or a new window if the box is
checked in the Open Location dialog) BUT it opens www.mozillazine.org instead.

This occurred on the following machines/builds:
MAC OS 8.5.1 with build 1999062110
Win 98 with build 1999062108
Linux with build 1999062108

Updated

19 years ago
Component: Apprunner → Browser-General
QA Contact: leger → cpratt

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
marking as a dupe of 8733. although it's slightly different, it's the same net problem with the same exact dialog. bug 8733
reflects the current behavior however. Is it possible File | Open was broken twice in two succesive days? (This first and then 8733)


*** This bug has been marked as a duplicate of 8733 ***

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: DUPLICATE → ---

Comment 2

19 years ago
As the QA Contact on this bug, I'm going to take it upon myself to reopen this
bug. Here's why:

8618: File | Open allows you to select a file, but that file isn't opened
8733: File | Open - the Select button is nonfunctional

If the two bugs can be traced to the same underlying problem in the code base,
would the assigned engineer for this bug please mark one as a duplicate? Thanks.

Comment 3

19 years ago
Though these bugs seem like different symptoms of the same bug, and this may
indeed be one fix to resolve both.  But they are two different testcase....so I
agree.  Leave this one open!

don, correct eng to fix?

Updated

19 years ago
Summary: can't open local file in browser → Using file picker to open file doesn't open file...

Comment 4

19 years ago
Hm. Actually, the problem is not well described in this bug. Using the
1999602408 build under NT, here's what's happening:

- Select File | Open
- Click the Choose Fileā€¦ button
- The Open Location dialog is displayed. [Note: it is not modal, but should be;
additionally, the title is incorrect. I believe there are other bugs that deal
with these issues.]
- Use the file picker to select a file, then click Open.
- When you do this, you should be returned to the Open Location dialog. However,
what happens is wrong: the browser spawns a new window.

Currently, it would seem that the only way to open a local file is by typing in
the path to the file. On Windows, for example, if you copy a HTML file to the
root directory of your C: drive, you can open it by doing this:

- Select File | Open
- Type "c:\foo.html"
- Press Enter

If this is done, foo.html correctly opens in the current window. [If you choose
to open the file in a new window, a new window is spawned, but it loads nothing.
I believe that bug, too, is filed elsewhere in Bugzilla.]

Based on this information, I'm changing the summary of this bug. Ideally, it
would be "Using file picker to open local file doesn't return to Select File
dialog and spawns new window with default page" but that's way too long. :)

Comment 5

19 years ago
*** Bug 8896 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: don → law
Status: REOPENED → NEW
Component: Browser-General → XPApps
Priority: P3 → P2
Target Milestone: M9

Comment 6

19 years ago
Bill, is this our bug?
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
OK, I'm treating this bug as per cpratt's most recent "summary."

File-picker limitations restrict our ability to get a file name and put it back
in the "Open file or location..." dialog.  This is covered (as stated) in other
bugs.  The current implementation is the best that could (can?) be done at the
time (open the selected local file in a new window).  I do see the selected file
opened (at least on my Windows build). I will verify that it works on Mac also.

So I don't think (pending test on mac) that there's any unique bug here.  Just
duplication of the other file-open one(s).  So after verification on the Mac, I
will close this as a dup of bug #9582.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 8

18 years ago
*** This bug has been marked as a duplicate of 9582 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.