Prepare for usability / user testing: capture testing and recruitment criteria, scenarios, and process for feedback

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: cassie, Assigned: cassie)

Tracking

Details

(Whiteboard: s=2013w29 p=1)

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

6 years ago
Whiteboard: uxdesign
Created attachment 738690 [details]
User/application flow for sign-up/sign-in

To be discussed, a possible application/user flow for signing in and signing up. Defers creation of user details until after user has already signed in
(Assignee)

Comment 2

6 years ago
Comment on attachment 738690 [details]
User/application flow for sign-up/sign-in

This makes sense to me, Kate. I'd be interested to verify with the Personas team to see if users can get put back on the page where they began the login / signup process once they are logged in, to keep the jarring-ness to a minimum. Is now a good time for me to reach out to Crystal?
(Assignee)

Updated

5 years ago
Whiteboard: uxdesign → uxdesign, s=2013w29

Updated

5 years ago
Whiteboard: uxdesign, s=2013w29 → s=2013w29 p=1
(Assignee)

Updated

5 years ago
Summary: Prepare for usability / user testing: write personas, recruitment criteria, scenarios, reimbursement → Prepare for usability / user testing: capture testing and recruitment criteria, scenarios, and process for feedback
(Assignee)

Comment 3

5 years ago
This bug has shifted quite a bit since it was filed. New goal is to create content / process that can be turned into a kit for use by the mentor team. Here are the current thoughts: https://etherpad.mozilla.org/usertestingwmo

Possible duplicate of bug 894981?
yep its a dupe. :) Cassie: which one do you want to use going forward?
(Assignee)

Updated

5 years ago
Duplicate of this bug: 894981
(Assignee)

Comment 6

5 years ago
Marked the other one a dupe, this one has some tracking on it already for this week.
We probably need 2 separate plans for user testing. The Mentor team/community is much more likely to be collecting data during actual workshops than scheduling formal user testing and focus groups. 

Every event the Mentor team facilitates outputs ideas/thoughts/bugs/feature requests from community. How can we be more systematic about feeding back? Sometimes we're very good at documenting things: 

For example: the massive spreadsheet from Reps Training Days when we asked 40+ Reps to write down the things MoFo could do to help them help us. https://docs.google.com/a/zythepsary.com/spreadsheet/ccc?key=0Aku8434q8_LPdHVHSU9CNlpkZVRZQ0U5Q0VtS0RhMHc#gid=6

Sometimes we have a bunch of post it notes in our bags that we intend to file as bugs. (JBuck can attest the number of times I've run a workshop in Toronto and delivered him post its to his desk.)

Just some thoughts to consider.
(Assignee)

Comment 8

5 years ago
These were helpful thoughts Laura, and Kat/Karen/Brett and I discussed some process for all this today. We'll have 3 ways of giving feedback:

1) we will translate testing questions into scenarios where feedback can be provided via google forms. Anyone can use these links to provide feedback online on their own, or with a mentor/leader guide at a maker party.

2) We'll do some formal user testing as well, thanks to Karen's help.

3) We'll create a section on our website, like webmaker.org/feedback, to house links for these google forms. There will also be a training video for how to gather good user feedback.

Our full meeting notes are here: https://etherpad.mozilla.org/usertestingwmo-meeting

Am going to close this bug as next steps are to break this into lots of smaller tasks. Karen and I will be translating the to-do tasks from that meeting into individual bugs (also as a bugzilla training session). Here's a minified list:

* prioritization of what we want to test that can be written into scenarios - brett
* guidelines/documentation for tagging on bugzilla - brett
* training - will create a video/guidelines on best practices in user testing - kat & karen, feat. on wm.org + demo it at webmaker call
* Kits / google forms:
    writing scenarios - cassie & karen
    translating to google forms - karen
    translating into bugs - cassie or brett
* Website page / general feedback form (webmaker.org/feedback) - Cassie
* Formal user testing - Karen
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.