Modify Cleopatra to support multi-thread profiling

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

6 years ago
I did some rough changes to support multiple timeline but they have many bugs remaining.

What I'd like to achieve:
* Support zooming correctly
* Sync up the thread timeline
* The diagnostic bar should select the proper thread
* Display markers in a more useful way

Here's a sample profile collected by bent that we display miserably. I think this is a good target to improve in this bug:
http://people.mozilla.com/~bgirard/cleopatra/#report=8987a832d7e5f7f224388eccf5b64a8e70919d6a
cc'ing anton. We'll do what we can to help out.
Comment 0 is mostly everything we need. Here are a few others that aren't entirely required but would make life much better:

* Allow threads to be hidden from UI
* Maybe disable recording on certain threads (performance on phone is very bad with all enabled)
* Make horizontal scrollbar always visible (currently you have to scroll to bottom of the tree view to see it)
Reporter

Updated

6 years ago
Blocks: 758697
Opened a PR to get feedback: https://github.com/bgirard/cleopatra/pull/1
Assignee: nobody → anton
Status: NEW → ASSIGNED
Reporter

Comment 4

6 years ago
Posted image Screenshot (WIP)
I've accepted Anton changes and have been adding a proper timeline and time markers. I plan on doing a few tweaks for improving the display of markers, diagnostics items and tertiary items before deploying it. Shouldn't be to long.

In the mean time here's the current WIP, feel free to give us early feedback.
Assignee: anton → nobody
Reporter

Updated

6 years ago
Duplicate of this bug: 767154
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.