Deleting multiple selections in download manager only delete one item

RESOLVED DUPLICATE of bug 844606

Status

()

RESOLVED DUPLICATE of bug 844606
6 years ago
6 years ago

People

(Reporter: van_vreckem, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

1 Open the download manager (ctrl+j)
2 Select a few completed download in the list
3 Press Del key 


Actual results:

The top most item selected in the list is deleted



Expected results:

Either all selected item should have been removed or prohibit multiple select.

Version 19 and earlier worked as expected, deleting all items selected.
Note that the delete of a few hundreds items used to be very slow and could trigger a script timeout warning due to high disk usage by sqlite.
So if you correct this, try to correct the delete speed issue by doing less fsync.

Comment 1

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

It works for me with FF 20.0.1 (Build ID: 20130409194949).

Are you able to reproduce this issue in safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode ?
Component: Untriaged → Downloads Panel
(Reporter)

Comment 2

6 years ago
Tested in safe mode, same build still doesn't work.

Comment 3

6 years ago
This happens for me as well. I’m using “Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 Iceweasel/21.0” from the mozilla.debian.net beta repository. The package identifies itself as 21.0~b2-1. I’m not sure where I can get the build id from – “browser.startup.homepage_override.buildID” pref says “20130412081511”.

Comment 4

6 years ago
It works now, after closing and re-opening the Library but without restarting Firefox.
(Reporter)

Comment 5

6 years ago
Tested on 5 more config, Same build for all installation:

1 Windows 7 x64
Same computer as my first test with a new user (fresh profil)
SUCCESS

2 Server 2008 x68 
Old firefox install (upgraded since 1) & old profil & safe | ~safe mode: 
FAILS the 2 tests

3 Windows 8 x64 with old firefox install (upgraded since 3.6) & old || semi fresh profil & with or without safe mode
FAILS the 4 tests

4 Windows XP with fresh firefox (first install) & fresh profil 
SUCCESS

Conclusion:
When there is a problems, it is with old upgraded user profiles.
I will try to copy a faulty profil piece by piece and see where it breaks.
(Reporter)

Comment 6

6 years ago
Ok, copying places.sqlite from an upgrade FF install to a working profile is sufficient to trigger the problem.
(Reporter)

Comment 7

6 years ago
Doing a Clear Downloads solve the problem on any installation...
The problem seems not linked to the number of items.
A fresh install with 700 downloads present no problem.
An old install with 150 downloads present the problem.
An old install with 1500 downloads present the problem.
An old install with 240000 downloads present the problem.

Only difference I see is that all old downloads lists present some entries with some information such as size shown as 'unknown' or simply unlisted.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 844606
You need to log in before you can comment on or make changes to this bug.