[Browser] CSS 3D transform demos (Three.js CSS3DRenderer) crash Firefox OS browser

RESOLVED DUPLICATE of bug 862097

Status

--
critical
RESOLVED DUPLICATE of bug 862097
6 years ago
6 years ago

People

(Reporter: p_os, Unassigned)

Tracking

({crash, reproducible, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-crash])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31

Steps to reproduce:

On TurkCell MaxPlus5 Test Driver device, Firefox OS 1.1.0.0-prerelease, last updated 04/11/2013 1:16 PM. 

Demonstration A:

1. Open Firefox OS browser
2. Type URL: http://bit.ly/css3d-per (this is a short URL for: http://mrdoob.github.io/three.js/examples/css3d_periodictable.html) and hit enter

Demonstration B:

1. Open Firefox OS browser
2. Type URL: http://bit.ly/css3d-mol (this is a short URL for: http://mrdoob.github.io/three.js/examples/css3d_molecules.html) and hit enter
3. Tap the link for LSD


Actual results:

Demonstration A:

 - Content is shown for a second (but without animation)
 - Screen flickers black, then changes to blue 'Firefox OS' launch screen, then the lock screen

Demonstration B:

 - Animation is very slow
 - Upon clicking LCD link, it brings up the "Well, this is embarassing" error page
 


Expected results:

Although animation (especially of the periodic table demo) should be expected to be slow on the low-end hardware, the demonstations shouldn't crash the browser.

NB. Both demos run OK in Firefox release browser on desktop, although animation of moving objects is much slower/jerkier than Chrome.
Please type about:crashes in the location bar and provide the crash ID.
Severity: normal → critical
Flags: needinfo?(p_os)
Keywords: crash, stackwanted
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [b2g-crash]
(Reporter)

Comment 2

6 years ago
Sorry, I've tried going to about:crashes, but it doesn't do anything (it just remains a blank white page, or whatever page I was last on) - after both crashes. Do I need to do something to enable it first?
Flags: needinfo?(p_os)
(In reply to Peter O'Shaughnessy from comment #2)
> Do I need to do something to enable it first?
Settings > Improve Firefox OS > Always send a report. You need also a Wi-Fi connection.
https://crash-stats.mozilla.com/report/index/0e85f1aa-8998-4431-b186-a17bd2130416

Was able to reproduce on a V1 train build using URL From Demonstration B.

about:crashes doesn't currently work to get crashes off the device. https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Getting_crashes_off_the_Device
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862097
You need to log in before you can comment on or make changes to this bug.