If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Java Crash : [@ java.lang.UnsupportedOperationException: Can''t convert to dimension: type=0x<n>: at android.content.res.TypedArray.getDimensionPixelSize(TypedArray.java) ] on Gingerbread devices

RESOLVED DUPLICATE of bug 862012

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 862012
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash})

20 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox20 affected)

Details

(Whiteboard: [native-crash], crash signature)

This bug was filed from the Socorro interface and is 
report bp-92193c6b-f889-4dc2-97e9-a0e432130415 .
============================================================= 
java.lang.UnsupportedOperationException: Can't convert to dimension: type=0x2
	at android.content.res.TypedArray.getDimensionPixelSize(TypedArray.java:463)
	at android.view.View.<init>(View.java:2108)
	at android.view.View.<init>(View.java:1899)
	at android.view.ViewGroup.<init>(ViewGroup.java:286)
	at android.widget.LinearLayout.<init>(LinearLayout.java:120)
	at org.mozilla.gecko.CheckableLinearLayout.<init>(CheckableLinearLayout.java:15)
	at java.lang.reflect.Constructor.constructNative(Native Method)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:415)
	at android.view.LayoutInflater.createView(LayoutInflater.java:505)
	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:570)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:386)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:320)
	at android.widget.SimpleAdapter.createViewFromResource(SimpleAdapter.java:121)
	at android.widget.SimpleAdapter.getView(SimpleAdapter.java:114)
	at android.widget.AbsListView.obtainView(AbsListView.java:1592)
	at android.widget.ListView.measureHeightOfChildren(ListView.java:1251)
	at android.widget.ListView.onMeasure(ListView.java:1162)
	at android.view.View.measure(View.java:8313)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3138)
	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1017)
	at android.widget.LinearLayout.measureVertical(LinearLayout.java:386)
	at android.widget.LinearLayout.onMeasure(LinearLayout.java:309)
	at android.view.View.measure(View.java:8313)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3138)
	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1017)
	at android.widget.LinearLayout.measureVertical(LinearLayout.java:386)
	at android.widget.LinearLayout.onMeasure(LinearLayout.java:309)
	at com.android.internal.widget.WeightedLinearLayout.onMeasure(WeightedLinearLayout.java:60)
	at android.view.View.measure(View.java:8313)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3138)
	at android.widget.FrameLayout.onMeasure(FrameLayout.java:250)
	at android.view.View.measure(View.java:8313)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3138)
	at android.widget.FrameLayout.onMeasure(FrameLayout.java:250)
	at android.view.View.measure(View.java:8313)
	at android.view.ViewRoot.performTraversals(ViewRoot.java:845)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:1865)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:130)
	at android.app.ActivityThread.main(ActivityThread.java:3687)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:867)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:625)
	at dalvik.system.NativeStart.main(Native Method)

More Reports : 
https://crash-stats.mozilla.com/report/list?signature=java.lang.UnsupportedOperationException%3A+Can%27%27t+convert+to+dimension%3A+type%3D0x2%3A+at+android.content.res.TypedArray.getDimensionPixelSize%28TypedArray.java%29

Devices:
java.lang.UnsupportedOperationException: Can''t convert to dimension: type=0x2: at android.content.res.TypedArray.getDimensionPixelSize(TypedArray.java) 	101
Samsung GT-I9000 	8
Samsung GT-S5360 	6
Samsung GT-I8150 	3
Samsung GT-I9100 	3
Samsung GT-I9070P 	3
LGE LGL55C 	3
Samsung GT-I8160 	3
Samsung GT-S5690 	3
HTC Desire HD A9191 	3
HTC ADR6350 	3
Samsung GT-I9001 	2
Samsung GT-S6102 	2
Samsung SCH-R920 	2
Samsung SC-02B 	2
TCT Telenor_OneTouch 	2
Samsung GT-S5830i 	2
Samsung GT-I9000T 	2
HUAWEI Huawei-U8665 	2
Samsung GT-S5830 	2
Samsung GT-S7500 	1
Samsung GT-S6102B 	1
Samsung GT-S6500D 	1
Samsung SC-03D 	1
Samsung SCH-I510 	1
Samsung SGH-I577 	1
TCT ALCATEL ONE TOUCH 903 	1
Sony Ericsson ST25i 	1
TOSHIBA AT100 	1
Unknown E619 	1
ZTE N860 	1
Yulong 5860E 	1
Sony Ericsson MT27i 	1
Samsung SPH-D700 	1
Samsung SGH-I727 	1
Samsung SGH-I717 	1
Samsung SGH-I897 	1
Samsung SGH-T679 	1
Samsung SGH-T769 	1
Samsung SCH-S720C 	1
Samsung GT-N7000 	1
LGE LG-P936 	1
LGE LG-P930 	1
LGE LG-P970 	1
LGE LG-VM696 	1
LGE VS910 4G 	1
LENOVO K1 	1
Huawei U8667 	1
HTC Desire HD 	1
HTC Desire S 	1
HTC PC36100 	1
HUAWEI H866C 	1
Lge LG-P990 	1
Micromax A54 	1
FUJITSU TOSHIBA MOBILE COMMUNICATIONS LIMITED IS11T 	1
Samsung GT-S5300B 	1
Samsung GT-S5360B 	1
Samsung GT-S5570B 	1
Samsung GT-I9220 	1
Samsung GT-I9103 	1
PANTECH PantechP9070 	1
Positivo Ypy 7 - TB07STA 	1
SHARP IS11SH 	1
Samsung GT-I9070 	1
Samsung GT-S5830C 	1

Note: looks like a regression from bug 832321 ( bug 815092 lead me to bug 832321 )
Not sure how I got 2 of the same bugs.  closing this one out as a dup.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862012
You need to log in before you can comment on or make changes to this bug.