[B2G] [Inari] [Email] User is unable to add attachments to an email

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Allen Maxwell, Assigned: olav)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 unaffected, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [status: needs ETA])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 737768 [details]
Screenshot

Repro Steps:
1) Updated to Commercial Build ID: 20130415070202
2) Add an email account to the phone.
3) Select Compose a message.
4) Observe attachment section.

Actual:
User is unable to add attachments to the email, it's missing a "+" button to add the attachments.

Expected:
User is able to add attachments to the email by pressing the "+" button.

Environmental Variables
Inari Version 1.0.1
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/2b44e2c40cc1
Gaia: c79e761bae4d92f329154c64159f4f5c8eb49c9e

Notes:
Repro frequency: 100%
See attached screenshot for more info.
inari is on 1.0.1, and attachment line is a 1.1 feature.

We should really either push the attachments into 1.0.1 or remove the attachment line when composing an email until the attachment is associated via the gallery due to user expectation.
blocking-b2g: --- → tef?
status-b2g18: --- → unaffected
status-b2g18-v1.0.1: --- → affected

Updated

5 years ago
Assignee: nobody → doliver
blocking-b2g: tef? → tef+
Keywords: regression
Giving to Andrew but reassign as approprite...
Assignee: doliver → bugmail
Olav, can you take a look at this one? We want to hide the attachments line in the 1.0.1 branch when you are in compose view.

You can discuss with Andrew in the #gelam channel.
Assignee: bugmail → olav
Hi Olav, once you have a chance to look at this, can you provide an estimate of when you can fix it by?
Whiteboard: [status: needs ETA]
(Assignee)

Comment 5

5 years ago
Hi! Looking at it now. Seems to be as easy as removing some html, but will ask Andrew if this is sufficient.
Olav, in v1.0.1, attachments can be added by the "share" activity from gallery.  In this case where the number of attachments is >= 1, we do want the attachments DOM node to be visible.  Otherwise it should be hidden.  Since the only way to add an attachment is when the card is first displayed and the DOM for the card is cloned from a template, it is indeed fine to remove the DOM node at that time.
(Reporter)

Comment 7

5 years ago
Created attachment 738140 [details]
Unagi email Screenshot

This is what is expected for the compose email.
(Assignee)

Comment 8

5 years ago
Created attachment 738488 [details] [review]
Proposed patch

Still an issue (regression) where input fields are positioned higher than on 1.1. Separate issue?
Comment on attachment 738488 [details] [review]
Proposed patch

This is r=squib from github and can land on v1.0.1 once the commits get squashed.
Attachment #738488 - Flags: review+
(In reply to Allen Maxwell from comment #7)
> Created attachment 738140 [details]
> Unagi email Screenshot
> 
> This is what is expected for the compose email.

No, that view is the expectation for 1.1 where you can add attachments from the email compose card -- this fix is for 1.0.1 where that feature is not yet available.
(Assignee)

Comment 11

5 years ago
Commit squashed ..

Comment 12

5 years ago
Landed on v1.0.1.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Marking 1.0.1 as fixed, could you please include a link to the commit? Thanks!
status-b2g18-v1.0.1: affected → fixed
Flags: needinfo?(olav)
(Assignee)

Comment 14

5 years ago
Here's the pull request that was merged: https://github.com/mozilla-b2g/gaia/pull/9241
Flags: needinfo?(olav)
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.