strict mode table row background to wide

RESOLVED FIXED

Status

()

Core
Layout: Tables
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Bernd, Assigned: Bernd)

Tracking

({testcase})

Trunk
x86
Other
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Assignee)

Description

17 years ago
In strict mode we draw the table row background to wide. It is a leftover from
some ancient days, we are off exactly by the cellspacing we introduce in the
paint method. All reflow debuuging shows to me that we the comment in the code
is no longer valid. testcase + patch will follow
(Assignee)

Comment 1

17 years ago
Created attachment 38738 [details]
testcase
(Assignee)

Comment 2

17 years ago
Created attachment 38739 [details] [diff] [review]
patch
(Assignee)

Updated

17 years ago
Keywords: patch, testcase
(Assignee)

Updated

17 years ago
r=dbaron.

I think there were other bugs like this from a taking a statement in CSS2 too
literally (the statement didn't mean what it said when saying that certain
backgrounds should "cover the entire table").  This is really a duplicate of bug
15931, anyway :-).

Do all the backgrounds in
http://www.people.fas.harvard.edu/~dbaron/css/test/sec170501
http://www.people.fas.harvard.edu/~dbaron/css/test/sec170501a
http://www.people.fas.harvard.edu/~dbaron/css/test/sec170501b
now look right or are there other bugs still around too?
See in particular Bert's comment in
http://lists.w3.org/Archives/Public/www-style/1999Jul/0083.html which is in
reply to one of the posts mentioned in bug 15931.
(Assignee)

Comment 5

17 years ago
Created attachment 38811 [details]
170501 and 170501a are rendered identical
(Assignee)

Comment 6

17 years ago
Created attachment 38812 [details]
rendering of 170501b

Comment 7

17 years ago
sr=attinasi

Comment 8

17 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
Blocks: 83989
(Assignee)

Comment 9

17 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.