If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][Everything.me]]Language]Application name overlap and don't change language with system language.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Everything.me
P2
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Whiteboard: [NPOTB] [apps watch list])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #440191 +++
 
 Created an attachment (id=390272)
 picture
 
 DEFECT DESCRIPTION:
 [Homescreen]]Language]Application name overlap and don't change language with system language.
 
  REPRODUCING PROCEDURES:
 1.Keep default language Poland,slide homescreen to the leftest,click more,add "Travel Guides".
 2.Long press one application,delete others remian only “Social" and "Travel Guides".Find their name overlap.->ko1
 3.Change system language to English,add "Baby" application,check“Social" and  "Baby" display in English,"Travel Guides" display in Poland.Change system language to Poland,check“Social" and "Travel Guides "display in Poland,"Baby" still display in English.->ko2
 
  EXPECTED BEHAVIOUR:
 ko1:no overlap.
 ko2:Change with system language.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 B2G-5654
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 3/3
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #440191 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 737826 [details]
picture

Clone from brother
Component: Gaia::Homescreen → Gaia::Everything.me
Summary: [Buri][Homescreen]]Language]Application name overlap and don't change language with system language. → [Buri][Everything.me]]Language]Application name overlap and don't change language with system language.

Updated

5 years ago
Summary: [Buri][Everything.me]]Language]Application name overlap and don't change language with system language. → [Buri][Homescreen]]Language]Application name overlap and don't change language with system language.
Ack. Bugzilla conflict. Sorry about that.
Summary: [Buri][Homescreen]]Language]Application name overlap and don't change language with system language. → [Buri][Everything.me]]Language]Application name overlap and don't change language with system language.

Updated

5 years ago
blocking-b2g: --- → tef?

Comment 4

5 years ago
Ran - we think the overlap is something that can be fixed server side by sending a shortened title "Travel Guid..."

We don't think we need to block on the system language change issue.
Assignee: nobody → ran
blocking-b2g: tef? → tef+
Whiteboard: [NPOTB]

Updated

5 years ago
Whiteboard: [NPOTB] → [NPOTB] [apps watch list1]
Hi Alex, I'm looking at this, and I have a couple of questions:
1) I couldn't reproduce the overlapping on master/Unagi, which branch/device should this be tested on?
2) This was a product decision. The basic set of shortcuts are translated to all languages, but the ones added through the More menu aren't- they stay in the language you added them. This is something that comes up about once a week on bugzilla, so if it's a blocker please open a separate bug on it and push through proper product channels (since it's obviously not a minor change to the code).
Flags: needinfo?(akeybl)
Status: NEW → ASSIGNED
Whiteboard: [NPOTB] [apps watch list1] → [NPOTB] [apps watch list]
Created attachment 745630 [details]
All long names are ellipsisized correctly.
Can't reproduce. All long names are ellipsisized correctly.
I attached an snapshot of my screen with long names in Spanish (don't have Polish)

Gecko: c0308d4
Gaia: 59d8c2e

Comment 8

5 years ago
Jason, please close this if it can't be reproduced.
Assignee: ran → jsmith
cheng-an, can you confirm this is fixed in your latest build? Thanks
Flags: needinfo?(chengan.xiong)
Flagging qawanted for a retest to see if this is fixed on the latest 1.01 build.
Assignee: jsmith → nobody
Keywords: qawanted

Comment 11

5 years ago
I tested this issue on the latest 1.0.1 build using the Inari device. 

The application names are not overlapped in e.me 

The apps that were selected from the "more" menu are still displayed in Polish after switching back to English. 

Build ID: 20130506070205
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/ce67220b877d
Gaia: 1e598d8842920d9e0b1743dc6fe9390bd5f6e2df
Version: 18.0
Keywords: qawanted
Hi Angela, please see comment #5 for info about the added shortcuts' translations.

Comment 13

5 years ago
(In reply to Joe Cheng [:jcheng] from comment #9)
> cheng-an, can you confirm this is fixed in your latest build? Thanks

ok on the sw of Mozilla build ID:20130430070201
Flags: needinfo?(chengan.xiong)
Closing per comment 11
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(akeybl)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.