Naughtly and sexual content in the settings menu

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: kami911, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 737843 [details]
The strange Naughty menu

I was able to get a Naughty menu from Settings. I do not know where it comes from but sounds weird. The Naughty menu contains list elements like Daily Babe+, Sex Tips - him+, etc. I grepped all across the gai a source but I haven't found it.

Steps to reproduce:
* Close Settings window
* Click on settings
* During inicialization phase (the whole menu is gereyd out) tap on Call Settings
* The menu will appear soon

I wasn't able to reproduce it with GP Peak but I can reproduce with Unagi (Boot2Gecko 1.1.0.0-prerelease, Chanel: beta, Build: 20130404070202)
Reporter said on IRC that they're using the Hungarian locale.
Kami,
That would be very helpful if you could send us your gaia settings app.

run this command:
adb pull /system/b2g/webapps/settings.gaiamobile.org

and attache the application.zip to this bug?

thanks!
(Reporter)

Comment 4

6 years ago
Created attachment 737901 [details]
The requested zip file from the phone
Could this be something coming from the SIM services?
(Reporter)

Comment 6

6 years ago
No SIM card in the phone. However if it can be cached then it could be, because I used this phone with SIM card.
(Reporter)

Comment 7

6 years ago
Stas(In reply to Staś Małolepszy :stas (needinfo along with cc, please) from comment #5)
> Could this be something coming from the SIM services?

Probably this content comes from providers. Searching for terms found carrier related results.
(Reporter)

Comment 8

5 years ago
I can't reproduce it anymore, I am closing it.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.