Make columns in Network Monitor resizable

RESOLVED DUPLICATE of bug 1358414

Status

enhancement
P2
normal
RESOLVED DUPLICATE of bug 1358414
6 years ago
5 months ago

People

(Reporter: st3fan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-backlog][difficulty=medium])

Reporter

Description

6 years ago
It is not possible to resize the columns of the network timeline. The 'File' column is truncated and I would like to resize it so that I can see the whole thing.
(In reply to Stefan Arentz [:st3fan] from comment #0)
> It is not possible to resize the columns of the network timeline. The 'File'
> column is truncated and I would like to resize it so that I can see the
> whole thing.

Did bug 859085 help? Would bug 861686 help even more? I would like to avoid the need to manually resize things around if at all possible, and find better solutions to this kind of problem (the UI should "just work by itself").
Reporter

Comment 2

6 years ago
Those bugs are useful features but not a solution to this one. I really just want to see a simple overview of requests without having to hover or copy. Why is resizing a list column an issue?
(In reply to Stefan Arentz [:st3fan] from comment #2)
> Why is resizing a list column an issue?

I think it may be worth considering finding better ways of dealing with such issues than picking the most immediate and easy solution (having the UI work for the user is better imho, as opposed to obliging the user to work for the UI).

For example, it may be more interesting for the columns to resize themselves in order to optimally occupy the available space (which is not currently implemented, but the foundations are being dealt with in bug 860175; this will give files a lot more visible room). Hiding certain columns (or picking which ones are visible) is also another way of looking at this.
OS: Mac OS X → All
Priority: -- → P3
Hardware: x86 → All

Comment 4

5 years ago
It seems to me that, especially as asset compilation becomes the norm, auto-sizing for the available space just isn't good enough.  Every other inspector on the market gives users the ability to manually resize the columns to give precedence to what's important at the moment, which changes often.  As it turns out, I know a bit more than my browser does when it comes to debugging my pages.
The table widget that is landing in Bug 993014 will have resizable columns.  If we migrated to the new widget once available that could resolve this.  Not sure how big of a job that will be.
Duplicate of this bug: 1082320
Depends on: 1149634
Uservoice issue for this: https://ffdevtools.uservoice.com/forums/246087-firefox-developer-tools-ideas/suggestions/5893909-ability-to-resize-columns-in-network-pane

Brian: bug 993014 has since been resolved but reading it I have no idea if it's going to help us here.
(In reply to Jeff Griffiths (:canuckistani) from comment #7)
> Brian: bug 993014 has since been resolved but reading it I have no idea if
> it's going to help us here.

As discussed, we need to land Bug 1149634 before we can swap out the table rendering in the netmonitor at all.  Multiple issues have been pointed out with the table widget -- we can either fix them and swap it into net monitor or integrate something else.  But I'd prefer that we have only a single table widget in the tree, so if we integrate a new one, we should also port the storage inspector over to it.

Updated

4 years ago
Whiteboard: [devedition-40]
Whiteboard: [devedition-40] → [devedition-40][difficulty=medium]
Whiteboard: [devedition-40][difficulty=medium] → [polish-backlog][difficulty=medium]

Updated

4 years ago
Duplicate of this bug: 1179066
Here's another use case for manually-resizable columns:

"I'm looking at a very long page load and I want the timeline graph to take the full width of the page so that not everything is squished to the left. Therefore, I resize every column to be 1 pixel wide except for the last one."

Alternatively, bug 862855 would allow me to directly hide the columns I don't care about and achieve the same result.
+1 for this. The new "Cause" column is often truncated and I can't resize it. For example I can never see full "subdocument" and "objectSubdoc". The tooltip for "Cause" is not ideal - it shows only the URL but not something like "subdocument from <some URL>".
Duplicate of this bug: 1265689
As of bug 1265689, I'm setting this to P2. I also changed the summary to read more like an enhancement (that it is) than a bug report.

Sebastian
Severity: normal → enhancement
Priority: P3 → P2
Summary: It is not possible to resize the columns of the network timeline → Make columns in Network Monitor resizable

Updated

2 years ago
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358414
This bug has some discussion on it and is much older than bug. Why did you mark this one as duplicate instead of the other one, Tim?

Sebastian

Comment 16

2 years ago
(In reply to Sebastian Zartner [:sebo] from comment #15)
> This bug has some discussion on it and is much older than bug. Why did you
> mark this one as duplicate instead of the other one, Tim?
> 
> Sebastian

Missed this comment, sorry! Most of the comments are either +1 or obsolete (comment 8 & comment 7 & comment 5), which is why I picked the new bug instead.

Updated

Last year
Product: Firefox → DevTools

Comment 17

5 months ago
is there some plan to finally fix this issue? It's pretty annoying when I cannot resize the columns by myself.
(In reply to lucie.triskova from comment #17)
> is there some plan to finally fix this issue? It's pretty annoying when I
> cannot resize the columns by myself.
Yes, the work is currently in progress.
You can track it in bug 1358414

Honza
You need to log in before you can comment on or make changes to this bug.