Balance SMS must be removed to avoid filling the SMS database

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Cost Control
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: salva, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(tracking-b2g:backlog, b2g18-)

Details

Due to automatic updates of remaining credit, several SMS can be received and they can fill the SMS inbox. These messages must be removed.
This doesn't sound like a valid bug - why do we need to remove?  Wouldn't the user choose to delete if they didn't want them taking up space?  If there's an issue with storage filling up, we need other mechanisms (space remaining warning, for example) - not to remove messages from a user's phone for them.  Product should weigh in here, re-nom if this is a user story I'm not aware of.
blocking-b2g: leo? → -
tracking-b2g18: ? → -
Flags: needinfo?(ffos-product)
This sounds like a nice to have whereby the operator uses SMS to update balance, but the user only ever sees the latest balance figure, instead of multiple messages.  I believe WAP Push is often used for this purpose, which isn't slated to be fully supported in the leo release.
Flags: needinfo?(ffos-product)
This has been discussed several times. The implications depend on SMS application as we could have been breaking the conversation threads. Should we think about this on 1.4?
blocking-b2g: - → 1.4?
Blocking for partner need in target market.
blocking-b2g: 1.4? → 1.4+
retriage: 1.4? and ni? Noemi for further information
blocking-b2g: 1.4+ → 1.4?
Flags: needinfo?(noef)
As Salva says in comment 3, the main problem is that SMS threading could be broken, it was the case in the past, I do not know if it still true or not, maybe Borja can give more details
Flags: needinfo?(borja.bugzilla)
Hi,

Users are able to manually remove messages from Messaging app so the issue is not so critical, in order to automatically handling "remove messages" functionality from CC app we would need UX input. Adding this to backlog to be considered in the incoming releases.
blocking-b2g: 1.4? → backlog
Flags: needinfo?(noef)
In this case, messages from 'Balance' can *not* be shown in the SMS App, due to those SMS were not sent by the user, were sent automatically through the Cost Control App.

This is due to the lack of a standard API for handling this. This was discussed a lot of times in the past, and probably it's time to talk with Salva - he did an awesome job here - and some folks in Gecko and Product for defining the future of a Balance API, trying to remove the workarounds we had in the past.

Related with the SMS workaround, sending and receiving 'SMS' which are not shown to the user produces an uncontrolled grow of the SMS DB (depends on the frequency we define in Cost Control APP), and this bug is related to 'clean' all these messages after being handled by Cost Control.

This type of 'silent' SMS should be transparent to the user (no user-action is required), and we should remove all these messages from the DB when received. I think that a WIP Patch should be easy to do & check, and if the threads appear in SMS App we could double check with Gecko team.
Flags: needinfo?(borja.bugzilla)
Resolved by Bug 1007590 -[Cost Control] Make Cost Control to remove balance and top-up SMS responses
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.