[CONTACTS] Backend is sending us duplicate (or triplicate some times) contacts

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Bebe, Assigned: reuben)

Tracking

unspecified
x86_64
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [fromAutomation][fixed-in-birch])

Attachments

(1 attachment)

STR:
1. open dialer
2. dial number
3. tap add contact
4. enter contact name
5. save
6. open contacts tab 

Expected:
6. The contact is added

Actual:
6. 2 exactly the same (duplicate) contacts are added in to contacts

This was found by:
http://qa-selenium.mv.mozilla.com:8080/job/b2g.unagi.gaia.v1-train.ui/520/testReport/%28root%29/TestDialerAddContact/test_dialer_add_contact/
Assignee: nobody → francisco.jordano
Taking a look to this.
Whiteboard: [fromAutomation]
We have been looking to this and the first impression is that backend is sending us the contacts duplicated (or triplicated) when using the cursor.

Asking our colleagues from backend to confirm this.

Thanks
Flags: needinfo?(reuben.bmo)
Assignee

Comment 3

6 years ago
I can't reproduce this on b2g18 + Gaia master, and I can't see anything in the backend code that looks like it could be causing this. I also just landed tests to getall that should make sure we don't do this (as long as it happens in desktop as well).

Francisco, as we discussed, please flag me again if you can reproduce this in an updated build.
Flags: needinfo?(reuben.bmo)
Flagging again Reuben :)

We both saw on the device how we were getting triple contacts when asking the backend.

Thanks!
Flags: needinfo?(reuben.bmo)

Comment 5

6 years ago
I am experiencing the same issue.
I also cannot add any contacts that start with the same letter as the contacts that got tripled. 

A separate bug has been logged for that issue. Bug 863017

Updated

6 years ago
Blocks: 863017
Rewording the bug title as may lead to errors.
Summary: [CONTACTS][DIALER] Adding a contact from dialer results on duplicate contacts → [CONTACTS] Backend is sending us duplicate (or triplicate some times) contacts
Assignee

Updated

6 years ago
Assignee: francisco.jordano → reuben.bmo
Component: Gaia::Contacts → DOM: Device Interfaces
Product: Boot2Gecko → Core
Assignee

Comment 7

6 years ago
Yes, this is an API bug, taking.
Flags: needinfo?(reuben.bmo)

Updated

6 years ago
blocking-b2g: --- → tef?
blocking-b2g: tef? → tef+
Whiteboard: [fromAutomation] → [fromAutomation][status: has patch, needs review gwagner]
Comment on attachment 739124 [details] [diff] [review]
Don't enqueue messages sent to a different inner window

Review of attachment 739124 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/contacts/ContactManager.js
@@ +474,5 @@
> +              debug(result[i].name);
> +            } else {
> +              debug("null contact");
> +            }
> +          }

Remove!
Attachment #739124 - Flags: review?(anygregor) → review+
Assignee

Updated

6 years ago
Whiteboard: [fromAutomation][status: has patch, needs review gwagner] → [fromAutomation][fixed-in-birch]
https://hg.mozilla.org/mozilla-central/rev/d1847d734c77
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Duplicate of this bug: 863723

Comment 14

6 years ago
Contacts are not duplicated nor triplicated when added to address book 

Unagi
Build ID: 20130501070205
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/765d296cff66
Gaia: e420d71c9528786621f176fb4ce67d291e0a530e
Assignee

Updated

6 years ago
Duplicate of this bug: 863017
You need to log in before you can comment on or make changes to this bug.