Viewing source of "about:" or some chrome XUL files gives JavaScript console error

VERIFIED FIXED in mozilla0.9.6

Status

SeaMonkey
UI Design
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: doctor__j, Assigned: timeless)

Tracking

Trunk
mozilla0.9.6

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010615
BuildID:    2001061309

Reproducible: Always
Steps to Reproduce:
1. Select "Help -> About" in browser.
2. View the source of the page.
3. JavaScript Console error is given:

Error: redeclaration of const kIOServiceProgID
Source File: chrome://communicator/content/utilityOverlay.js
Line: 1
That's odd.  It only seems to be declared once.

Comment 2

17 years ago
over to XPApps GUI Features.
Assignee: asa → blake
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
At a guess....  The scripts that viewSource.xul loads are executed in some
existing context for some reason and we get this error as a result.

No clue why something like that would happen, though....
*** Bug 85855 has been marked as a duplicate of this bug. ***
*** Bug 87918 has been marked as a duplicate of this bug. ***
OS: Windows 98 → All
Hardware: PC → All
Summary: Viewing source of "about:" gives JavaScript console error → Viewing source of "about:" or some chrome XUL files gives JavaScript console error

Comment 6

17 years ago
it it really an error, or should it be a warning?  What does this error prevent?
Does it break some functionality?  
(Reporter)

Comment 7

17 years ago
It's getting worse.

The error message comes up even when viewing a simple HTML file.

Comment 8

16 years ago
I saw this (or something similar) with today's build
*** Bug 102415 has been marked as a duplicate of this bug. ***
*** Bug 102617 has been marked as a duplicate of this bug. ***
*** Bug 102801 has been marked as a duplicate of this bug. ***
*** Bug 103253 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
This can be fixed by removing a single line from viewSource.xul. It's this line btw:

<script type="application/x-javascript"
src="chrome://communicator/content/utilityOverlay.js"/>
/HJ
HJ, that would disable half the menuitems and key commands in view source.  Not
a good fix.
actually, this does fix it, as navigatorOverlay includes utilityOverlay.xul,
which then includes the .js
(Assignee)

Comment 16

16 years ago
Created attachment 52264 [details] [diff] [review]
remove manual inclusion of utilityOverlay (it's chain included via xul overlays)
(Assignee)

Comment 17

16 years ago
i figured this out yesterday... sorry for the long delay.
Assignee: blakeross → timeless
Comment on attachment 52264 [details] [diff] [review]
remove manual inclusion of utilityOverlay (it's chain included via xul overlays)

r=bzbarsky.  Can we get this in for 0.9.5?
Attachment #52264 - Flags: review+

Comment 19

16 years ago
Comment on attachment 52264 [details] [diff] [review]
remove manual inclusion of utilityOverlay (it's chain included via xul overlays)

sr=darin
Attachment #52264 - Flags: superreview+
thanks for fixing this timeless
Target Milestone: --- → mozilla0.9.5
asa says not stop-ship, -> 0.9.6. sorry for the spam
Target Milestone: mozilla0.9.5 → mozilla0.9.6
Checked in for timeless; he's out of town and asked me to do it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 105767 has been marked as a duplicate of this bug. ***
i don't see the error originally reported in this bug. but i now see the following:

Error: popup has no properties
Source File: chrome://messenger/content/mailNavigatorOverlay.xul
Line: 58
Error: popup has no properties
Source File: chrome://editor/content/editorApplicationOverlay.js
Line: 82

using 2001.11.01.12 bits on linux.

reopening. but, if this new issue should be filed seperately, go ahead and
re-resolve this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
that's a separate issue.  File it on Ben (his overlays)
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 26

16 years ago
*** Bug 108700 has been marked as a duplicate of this bug. ***
okay, verifying this one.

filed bug 108745 for the newer js errors i see.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
(Assignee)

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.