update vendor-local and prod.txt

RESOLVED FIXED in 3.2

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Pike, Assigned: Pike)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
prod.txt doesn't match what's in vendor-local/lib/python right now.

Also, versiontools got added for django_compressor, but not removed when that moved to funfactory.

I'm tempted to sneak in updates to at least pytz (2012d to 2013b) and feedparser (5.1 to 5.1.3)

Not sure about raven (3.1.16 to 3.3.3).

Peter, are there tests that would catch possible regression in our ties to those?
Which one should be a dupe of which? 
https://bugzilla.mozilla.org/show_bug.cgi?id=861944
(Assignee)

Updated

5 years ago
Duplicate of this bug: 861944
(Assignee)

Comment 3

5 years ago
Created attachment 738248 [details] [diff] [review]
remove versiontools, update requirements/prod.txt

This patch just updates prod.txt to match what's in vendor-local/lib/python, and removes versiontools. We added that for django_compressor, but that one's in funfactory now.

Our version of memcache isn't on pypi, so I added the explicit download url of the tarball instead.
Attachment #738248 - Flags: review?(peterbe)
Attachment #738248 - Flags: review?(peterbe) → review+

Comment 4

5 years ago
Commit pushed to develop at https://github.com/mozilla/elmo

https://github.com/mozilla/elmo/commit/0ab8066b3641b3c8d9d0ff8118bc156323a75928
bug 862407, clean up vendor-local and prod.txt, r=peterbe
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.2
You need to log in before you can comment on or make changes to this bug.