replace_corrupted_hg_master requires abs path to repo

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: hwine, Assigned: hwine)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [re-vcs-sync])

Attachments

(1 attachment)

absolute path to repo required, but not enforced.

Drop requirement or enforce
Created attachment 746475 [details] [diff] [review]
force absolute path

Several changes:
 1. use absolute paths for repositories
 2. remove extra repository verifications that have not been needed. We understand the root cause better, and no longer need that double check. They take a lot of time to run.
 3. be more cautious in saving copies of key files, such as the git-mapfile

Has been run successfully with these changes.
Assignee: nobody → hwine
Status: NEW → ASSIGNED
Attachment #746475 - Flags: review?(aki)

Comment 2

6 years ago
Comment on attachment 746475 [details] [diff] [review]
force absolute path

I'll take your word on it for the abs_path logic.
Attachment #746475 - Flags: review?(aki) → review+
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.