[B2G][Inari][Gallery]: Seek in landscape mode does not function smoothly while playing a video.

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Gallery
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Darren, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: inarirun1)

(Reporter)

Description

5 years ago
Description:
While playing a video in landscape mode the seek bar,if dragged, does not smoothly move left or right. The user will also experience this while in the camera app and viewing the video.

Repro Steps:
1) Updated to Inari Build ID: 20130416070200
2) Take a Video around a minute long/ have a video on the micro SD card.
3) Open the Gallery app.
4) Select the video.
5) Hold the phone in landscape mode.
6) Play the Video
7) Press and hold on the seek bar.
8) Move the bar left or right.

Actual:
The seek bar will jump to the end of the video then start moving in the wrong direction when moved to the left.

Expected:
The seek bar will move left and right smoothly to let the user pick a desired spot in the video.

Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6bac24e14538
Gaia: c883af5ecd0998f78d9aaa4c2337c842e1dbb5a0

Notes:
Repro frequency: 3/3 100% on 2 devices.
Test Suite Name: Camera
UCID: camera-031
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-id=2865

Also sometimes the video will stop playing when seeked to a specific location.

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Comment 1

5 years ago
Issue no longer reproduces on the following Inari build:

Environmental  Variables:
Inari Build ID: 20130501070201
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/010498e599a7
Gaia: 09046df332cd217cf4fad55c48ce9ce3f14ee5a4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

5 years ago
Scrolling while in landscape mode looks like it works much smoother.

Verified as WorksForMe in build -
Build ID: 20130820041204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bc2c6813842e
Gaia: 849cee8a3ee5a2a6f4e39183549d36c3acc05f2f
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.