If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

VariablesView needs a way to display the contents of Maps and Sets (and maybe WeakMaps)

RESOLVED DUPLICATE of bug 1172920

Status

()

Firefox
Developer Tools: Object Inspector
P3
normal
RESOLVED DUPLICATE of bug 1172920
5 years ago
2 years ago

People

(Reporter: benvie, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Since there's no direct way to see the contents of Maps, Sets, and WeakMaps, we should provide some interface in the VariablesView to view this information. It should be denoted differently from a property so users don't confuse it for directly accessible properties.

bug757185 is about adding the ability to view the contents of collections to Debugger but I'm not going to mark it as blocking this for now. It's possible to implement enumeration of contents for Maps and Sets entirely from JS so we shouldn't let that be a blocker.
(Reporter)

Updated

5 years ago
Depends on: 866877
(Reporter)

Updated

4 years ago
Component: Developer Tools → Developer Tools: Object Inspector
Priority: -- → P3
Version: 21 Branch → unspecified

Updated

4 years ago
Depends on: 757185

Updated

4 years ago
Duplicate of this bug: 966177
Duplicate of this bug: 1064896
No longer depends on: 757185
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1172920
You need to log in before you can comment on or make changes to this bug.