Closed Bug 862679 Opened 7 years ago Closed 6 years ago

integrated pdf prints black areas outside paper area

Categories

(Firefox :: PDF Viewer, defect, P2)

20 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 24
Tracking Status
firefox22 --- verified
firefox23 --- verified
firefox24 --- verified

People

(Reporter: jonathan.n.mills, Assigned: bdahl)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-printing][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3182)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Print a PDF document (on A4 paper)


Actual results:

The right edge and bottom has a black line which isn't there on the one printed by the Adobe reader.  Additionally, where the page is rotated, the areas outside the paper area is filled in black, which is unsightly and expensive in terms of printer ink!

Printing with scale factors to shrink the page also get black areas on the unprinted areas.


Expected results:

If nothing else, there ought to be an option to have white instead of black background. However arguably this default ought to be white out of the box.
Component: Untriaged → PDF Viewer
Priority: -- → P2
Whiteboard: [pdfjs-c-rendering][pdfjs-d-printing]
Whiteboard: [pdfjs-c-rendering][pdfjs-d-printing] → [pdfjs-c-rendering][pdfjs-d-printing][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3182
Attached patch aurora patchSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: If the user enables printing background colors/images the background will be black when the pdf size doesn't match the paper size.
Testing completed (on m-c, etc.): hasn't landed m-c, but will be in the next pdf.js update
Risk to taking this patch (and alternatives if risky): very low risk, css change for content code 
String or IDL/UUID changes made by this patch: none
Attachment #746058 - Flags: review?(ydelendik)
Attachment #746058 - Flags: approval-mozilla-aurora?
Attached patch beta patchSplinter Review
[Approval Request Comment]
same as above
Attachment #746062 - Flags: review?(ydelendik)
Attachment #746062 - Flags: approval-mozilla-beta?
Attachment #746058 - Flags: review?(ydelendik) → review+
Attachment #746062 - Flags: review?(ydelendik) → review+
Comment on attachment 746062 [details] [diff] [review]
beta patch

Although a simple patch but we have already gone to build for our final beta build for Fx21 not approving for beta, this looks good to go on aurora though
Attachment #746062 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
(In reply to Brendan Dahl from comment #1)
> Testing completed (on m-c, etc.): hasn't landed m-c, but will be in the next
> pdf.js update

Do we know when this will land to m-c? We'll skip process and uplift sooner if need be, but would rather not.
We're hoping Friday, but we're still waiting on a few bugs we need to fix before updating.  If it's not looking like it will make it by the end of Thursday I'll create a patch for m-c.
Comment on attachment 746058 [details] [diff] [review]
aurora patch

Approving for Aurora 23 and Beta 22 - we don't want to wait any longer for the m-c patch at this point.
Attachment #746058 - Flags: approval-mozilla-beta+
Attachment #746058 - Flags: approval-mozilla-aurora?
Attachment #746058 - Flags: approval-mozilla-aurora+
Update to m-c will be take care of by bug 871530.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/aaf5d70ba693
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified as fixed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (20130521223249).
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (20130725195523)
Verified as fixed on Firefox 24 beta 1 (20130806170643) on Windows 7 64bit, Mac OSX 10.8.4 and Ubuntu 13.04 32bit.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.