[Buri][Notification]Still has notification vibrate under silent mode.

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.070
 Firefox os  v1.0.1
 Mozilla build ID:20130407070205
 
 +++ This bug was initially created as a clone of Bug #440588 +++
 
 DEFECT DESCRIPTION:
 [Notification]Still has notification vibrate under silent mode.
 
  REPRODUCING PROCEDURES:
  Set device to silent mode,enter settings->notification,enable vibrate,make an incoming call,don't deal with it,will still has notification vibrate.->ko
 
  EXPECTED BEHAVIOUR:
 No vibrate.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 B2G-7173
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 3/3
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #440588 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Comment 1

5 years ago
Dear all,
Under silent(or mute) mode:

If we enable the vibration of Notification, there still is a vibration when the phone receive notification.

Similarly, if we enable the vibration and click sound of Keyboard, there still are sound and vibration when we press the keyboard.

So I think we should add a condition(isMute??) in the gecko when the apps in gaia called navigator.vibrate or sound.play. By this, when the phone is under mute mode, the vibrate or sound will be disabled everytime.

Updated

5 years ago
blocking-b2g: --- → tef?

Updated

5 years ago
blocking-b2g: tef? → ---

Comment 2

5 years ago
Dear all,
Can you guys find someone to check this??? Imagine this scene: in the mute mode, we lunch a app of third party, the app also can vibrate in the mute mode. So we need to do changes in the gecko, so that any app can't vibrate in the mute mode.

Comment 3

5 years ago
Dear khu,
Can you find someone to check this, or give me some advice about this.
Flags: needinfo?(khu)

Comment 4

5 years ago
Hi, Keven, is it something you or your team can help here? Thank you!
Flags: needinfo?(khu) → needinfo?(kkuo)

Updated

5 years ago
Flags: needinfo?(kkuo)

Comment 5

5 years ago
Hi there,
Can you find me someone to check this?
Flags: needinfo?(nhirata.bugzilla)
I cannot reproduce this issue. with leo, nor inari.

There's 2 settings when you use the hardware button to turn the sound all the way down.
It switches to vibration only, no sound once you have no bars and then pressing one more time down will give you no vibration, no sound.

- If vibration is off, prior to moving the volume down the phone will turn vibration on.
- If you move from vibration mode on and press volume up, the vibration mode stays on.
- If you move down from vibration mode to complete silent mode and then move up, vibration mode will stay off.

- You will see the squiggly icon if it's in vibration mode.
Flags: needinfo?(nhirata.bugzilla)
Created attachment 747625 [details]
silent mode : lockscreen

Lockscreen will show silent mode.
Created attachment 747628 [details]
no vibration silent mode

see screenshot at the top of the screenshot where the volume is.
Created attachment 747630 [details]
vibration mode

see screenshot to see vibration mode.  you can verify by checking settings -> sound

I believe this bug is invalid.

Comment 10

5 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #9)
> Created attachment 747630 [details]
> vibration mode
> 
> see screenshot to see vibration mode.  you can verify by checking settings
> -> sound
> 
> I believe this bug is invalid.
Yes,you're right. Thanks for your explain.
Flags: needinfo?(kkuo)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.