Spaces outside wrapped inline elements lost when wrapping [INLINE]

RESOLVED FIXED in Future

Status

()

Core
Layout
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: Chris Waterson)

Tracking

({css1, testcase})

Trunk
Future
x86
Windows 2000
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P3], URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
   1. http://hixie.ch/tests/adhoc/css/box/inline/003.xml
   2. Resize the window, back and forth.

EXPECTED RESULTS
   The words run into each other -- the spaces separating their respective
   inline elements are lost.

ACTUAL RESULTS
   Any spaces not actually at the end of a line should be shown. Spaces at the
   end of a line (when white-space: normal) should be silently dropped when
   they turn into a line break.

You can see this with these testcases and pages:
   http://www.damowmow.com/mozilla/xml-not-xhtml.xml
   http://www.hixie.ch/tests/adhoc/css/box/inline/003.xml
   http://www.hixie.ch/tests/adhoc/css/box/inline/004.xml
   http://www.hixie.ch/tests/adhoc/css/box/inline/005.xml

(Note. Some of these pages, especially the first and the fourth, have other
known bugs visible on them.)
(Reporter)

Updated

17 years ago
Keywords: css1, mozilla1.0, testcase
Whiteboard: [Hixie-P3]
(Reporter)

Comment 1

17 years ago
Created attachment 38805 [details]
Screenshot of http://www.hixie.ch/tests/adhoc/css/box/inline/004.xml (Xs should be aligned in a grid)
(Reporter)

Comment 2

17 years ago
Uh, I got EXPECTED RESULTS and ACTUAL RESULTS the wrong way round. My bad. :-/

Comment 3

17 years ago
Created attachment 59310 [details]
Example of lost white space after window resize

This bug can be seen in a plain HTML 2.0 document with hyperlinks (or any
inline
element). Shoudn't it get a higher priority? Looks like a data loss to me.
See attachment for a real (not very good but you get the idea) example of what
can happen when a white space is (visually) lost.
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
(Reporter)

Comment 4

17 years ago
I believe this is fixed.
(Assignee)

Comment 5

17 years ago
Yes, looks to be. Marking thus!
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.