Deleting two or more messages causes jump to last message

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Ilya Konstantinov, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Select two or more messages in your mailbox.
2. Delete them.

Expected result: The selected messages would be unselected and the currently
selected message would become the next non-deleted message after the first
message you just deleted.
Actual result: The selected messages are unselected, and the last message in the
mailbox gets selected (despite being deleted and new messages being available).

Comment 1

17 years ago
duplicate 86385?

Comment 2

17 years ago
*** Bug 86385 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Does anyone still see this bug? Testing with current CVS, Linux. POP3 accounts:

-Selected two messages in the middle of inbox
-Hit delete button

Result:
Deleted messages were deleted, summary no longer displayed.
Selection was moved to the next undeleted message following first deleted msg.

Illustrating:

1
2 selected
3
4 selected
5
6

Hit delete - new scenario becomes:

1
3 selected
5
6


Works for me.

Comment 4

16 years ago
Yup, it's still here.  Linux nightly -sea 2001121408, IMAP.
(Reporter)

Comment 5

16 years ago
Mozilla 1.0RC1. No longer reproducible on Linux. Upon deleting, selection stays
on the currently selected message.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
verififed per reporter's comments - in the future, please use 'worksforme'
unless you can point to a patch that fixed the bug.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.