Closed Bug 862972 Opened 8 years ago Closed 8 years ago

[ja] Failure "'Phishing protection' element has been found - got 'false'" in testSafeBrowsingWarningPages.js::testWarningPages (ja-JP)

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P3)

defect

Tracking

(firefox21 fixed, firefox22 fixed, firefox23 fixed, firefox24 fixed, firefox-esr17 fixed)

RESOLVED FIXED
Tracking Status
firefox21 --- fixed
firefox22 --- fixed
firefox23 --- fixed
firefox24 --- fixed
firefox-esr17 --- fixed

People

(Reporter: u279076, Assigned: mario.garbi)

References

()

Details

(Whiteboard: [mozmill-test-failure])

Attachments

(1 file)

I noticed a failure today when testing Firefox 21.0b3 candidates. This only happened once on Mac OSX 10.7 with the 21.0b3#1 ja-JP-mac build.

> 'Phishing protection' element has been found - got 'false'
We never tested this locale, so there might be issues. Lets put this up as a mentored bug for now.
Priority: -- → P3
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mentor=andreea.matei][lang=js][good first bug]
Summary: Failure in testSafeBrowsingWarningPages.js::testWarningPages → Failure "'Phishing protection' element has been found - got 'false'" in testSafeBrowsingWarningPages.js::testWarningPages (ja-JP)
Also happened with the 21.0b5 win32 ja build today on Windows 8 64-bit:
http://mozmill-ondemand.blargon7.com/#/functional/report/49feb8c5f96a46e9037cffdde18fe156
OS: Mac OS X → All
Hardware: x86_64 → All
Can someone please quickly run a ja build to check what's wrong with it? Would be good to know if that's our fault or an issue with Firefox.
Summary: Failure "'Phishing protection' element has been found - got 'false'" in testSafeBrowsingWarningPages.js::testWarningPages (ja-JP) → [ja] Failure "'Phishing protection' element has been found - got 'false'" in testSafeBrowsingWarningPages.js::testWarningPages (ja-JP)
It reproduces locally every time, I will investigate this and come back with more info in the following hours.

http://mozmill-crowd.blargon7.com/#/functional/report/ea82256a8ae9808d91b7e8145e175a4f
This seems to have also failed on 26.04 with ondemand_functional Ja locale and we didn't seem to have any ja jobs (i've gone back to September 2012).
http://mozmill-ondemand.blargon7.com/#/functional/reports?branch=All&platform=All&from=2012-09-01&to=2013-05-08

I am investigating this but like in Bug 835132 case the fact that I do not understand the language makes the investigation a bit slow.
After investigating I have noticed that the JA locale does not act the same way the en-US acts when we press the reportButton. We are basically looking for an element with an ID that doesn't exists on the JA locale.

JA locale report page:
http://www.mozilla.jp/firefox/security/phishing-protection/ 
JA locale ID:
id="firefox-security-protection"

en-US report page:
http://www.mozilla.org/en-US/firefox/phishing-protection/firefox2/
en-US ID:
id="phishing-protection"
I think we have to remove both of the element checks in that test given that different websites exists for the different locales. We can only check for the correct final URL been loaded.
Assignee: nobody → mario.garbi
Status: NEW → ASSIGNED
Comment on attachment 747345 [details] [diff] [review]
patch v1.0

Review of attachment 747345 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/testSecurity/testSafeBrowsingWarningPages.js
@@ -86,5 @@
>    if (type == 0) {
>      // Build phishing URL be replacing identifiers with actual locale of browser
>      url = utils.formatUrlPref("browser.safebrowsing.warning.infoURL");
> -
> -    var phishingElement = new elementslib.ID(controller.tabs.activeTab, "phishing-protection")

Considering this is not failing on our 4 tested locales, can't we add an if with the locale here, if is at least en-US, to check this code? 
I don't seem to find the testcase for this test giving that litmus is no longer available. I did find the creation bug 503411, but does not include the steps.

Henrik, what do you think?
Comment on attachment 747345 [details] [diff] [review]
patch v1.0

Review of attachment 747345 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/testSecurity/testSafeBrowsingWarningPages.js
@@ -86,5 @@
>    if (type == 0) {
>      // Build phishing URL be replacing identifiers with actual locale of browser
>      url = utils.formatUrlPref("browser.safebrowsing.warning.infoURL");
> -
> -    var phishingElement = new elementslib.ID(controller.tabs.activeTab, "phishing-protection")

No. Each locale could be different and having special code for en-US only doesn't make that much sense. Checking that we have loaded the correct target page should be the check to do.
Comment on attachment 747345 [details] [diff] [review]
patch v1.0

Review of attachment 747345 [details] [diff] [review]:
-----------------------------------------------------------------

Landed on default, we want to remove the element checks from all branches.
http://hg.mozilla.org/qa/mozmill-tests/rev/05730582186d (default)
Attachment #747345 - Flags: review?(andreea.matei) → review+
Lets get the patch tested with beta and release for a couple of locales (LRT, RTL, Asian, Europe, India) on different platforms. If it works lets get it backported today, given that we cannot prove it in our CI due to missing jobs.
I have ran functional tests against different locales as requested, so far "ar" and "de" presenting a few issues but the test treated in this bug seems to work ok. It would seem both Release and Beta ran with 21 build.

The locales I've used are: ja, zh-TW, ar, de, gl, ro.

http://mozmill-crowd.blargon7.com/#/functional/reports?branch=21.0&platform=All&from=2013-05-15&to=2013-05-16
Thanks Mario, so lets get this backported to all the older branches then. Andreea, can you do that?
Sounds good. What about the other branches for those failing locales? Does it work too? We could then backport the patch in on go.
Oh, missed that you already did that. My fault. I have transplanted the patch to all other branches:

http://hg.mozilla.org/qa/mozmill-tests/rev/66908c9dfac0 (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/e55b46b5129d (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/2520b9439f2b (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/21a9424d5762 (esr17)
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [mozmill-test-failure][mentor=andreea.matei][lang=js][good first bug] → [mozmill-test-failure]
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.