DataChannel causes 5450 bytes leaked (DtlsIdentity, Mutex, NrIceCtx, NrIceMediaStream, NrIceResolver, ...)

RESOLVED DUPLICATE of bug 862744

Status

()

Core
WebRTC: Networking
RESOLVED DUPLICATE of bug 862744
5 years ago
5 years ago

People

(Reporter: whimboo, Assigned: jesup)

Tracking

({mlk, regression})

23 Branch
mlk, regression
Points:
---

Firefox Tracking Flags

(firefox23 affected)

Details

(Whiteboard: [MemShrink][WebRTC][blocking-webrtc+][webrtc-uplift])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 738750 [details] [diff] [review]
leaking mochitest

With the attached patch applied to the current m-c changeset the basic audio peerconnection test will cause various leaks:

TEST-INFO | leakcheck | leaked 1 DtlsIdentity (32 bytes)
TEST-INFO | leakcheck | leaked 2 Mutex (48 bytes)
TEST-INFO | leakcheck | leaked 1 NrIceCtx (192 bytes)
TEST-INFO | leakcheck | leaked 3 NrIceMediaStream (504 bytes)
TEST-INFO | leakcheck | leaked 1 NrIceResolver (40 bytes)
TEST-INFO | leakcheck | leaked 18 NrSocket (3600 bytes)
TEST-INFO | leakcheck | leaked 1 ReentrantMonitor (32 bytes)
TEST-INFO | leakcheck | leaked 2 StringAdopt (2 bytes)
TEST-INFO | leakcheck | leaked 1 TransportFlow (176 bytes)
TEST-INFO | leakcheck | leaked 1 VerificationDigest (88 bytes)
TEST-INFO | leakcheck | leaked 1 nsDNSService (144 bytes)
TEST-INFO | leakcheck | leaked 1 nsIDNService (120 bytes)
TEST-INFO | leakcheck | leaked 1 nsPrefBranch (128 bytes)
TEST-INFO | leakcheck | leaked 1 nsSocketTransportService (216 bytes)
TEST-INFO | leakcheck | leaked 1 nsStringBuffer (8 bytes)
TEST-INFO | leakcheck | leaked 1 nsTimerImpl (96 bytes)
TEST-INFO | leakcheck | leaked 1 nsUnicodeNormalizer (24 bytes)
 0:14.33 TEST-UNEXPECTED-FAIL| leakcheck | 5450 bytes leaked (DtlsIdentity, Mutex, NrIceCtx, NrIceMediaStream, NrIceResolver, ...)


Steps:
1. Apply patch
2. Run: ./mach mochitest-plain dom/media/tests/mochitest/test_peerConnection_basicAudio.html
3. Once the test has been finished close the browser
4. Check the leak output
Assignee: nobody → rjesup
Whiteboard: [MemShrink][WebRTC][blocking-webrtc?] → [MemShrink][WebRTC][blocking-webrtc+]
(Reporter)

Comment 1

5 years ago
The number of bytes leaked varies between different runs. Today it went up to 15kB in one case.
Whiteboard: [MemShrink][WebRTC][blocking-webrtc+] → [MemShrink][WebRTC][blocking-webrtc+][webrtc-uplift]
(Assignee)

Comment 2

5 years ago
This *looks* like a failure of a transportflow to get shut down at test end; there are no DataChannel objects leaked....  

Can you upload the full output with NSPR_LOG_MODULES=signaling:5,mtransport:5,datachannel:5
?

Thanks!
(Reporter)

Comment 3

5 years ago
Created attachment 739552 [details]
logfile

The log file as requested. I just want to add (if it matters) that I'm running a debug optimized build with trace-malloc enabled. I will rebuild without optimizations now.
(Reporter)

Comment 4

5 years ago
This leak is a regression caused by the first patch landed on bug 862744 and will be fixed once the second patch on that bug has been landed in mozilla-central.
Blocks: 862744
status-firefox23: --- → affected
tracking-firefox23: --- → ?
Keywords: regression
(Assignee)

Comment 5

5 years ago
Dupping since the bug is being handled by reopening bug 862744 (and that fix is already on inbound)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862744
tracking-firefox23: ? → ---
You need to log in before you can comment on or make changes to this bug.