Closed Bug 863095 Opened 9 years ago Closed 9 years ago

Don't refresh AboutHomeContent in onResume()

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox21 fixed, firefox22 verified, firefox23 unaffected)

VERIFIED FIXED
Tracking Status
firefox21 --- fixed
firefox22 --- verified
firefox23 --- unaffected

People

(Reporter: bnicholson, Assigned: bnicholson)

References

Details

Attachments

(1 file)

Bug 859584 creates pending thumbnails that wait until a layout pass to be added. This should act as an alternative to bug 838440, so we shouldn't need to refresh about:home in onResume() any more. This can give us a performance win any time we switch from another activity (including the AwesomeScreen).

Bug 838793 already includes this change, so we don't need this in Fx23, but this should be uplifted to Fx21/22 with bug 859584.
Attachment #738809 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 738809 [details] [diff] [review]
Don't refresh AboutHomeContent in onResume()

Review of attachment 738809 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Attachment #738809 - Flags: review?(lucasr.at.mozilla) → review+
Comment on attachment 738809 [details] [diff] [review]
Don't refresh AboutHomeContent in onResume()

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 838440
User impact if declined: slower performance when switching activities
Testing completed (on m-c, etc.): m-c (since this change is part of bug 838793)
Risk to taking this patch (and alternatives if risky): low risk
String or IDL/UUID changes made by this patch: none

Note: This should not be uplifted to beta without bug 838793.
Attachment #738809 - Flags: approval-mozilla-beta?
Attachment #738809 - Flags: approval-mozilla-aurora?
(In reply to Brian Nicholson (:bnicholson) from comment #3)
> 
> Note: This should not be uplifted to beta without bug 838793.

Correction: This should not be uplifted to beta without *bug 859584*.
Attachment #738809 - Flags: approval-mozilla-beta?
Attachment #738809 - Flags: approval-mozilla-beta+
Attachment #738809 - Flags: approval-mozilla-aurora?
Attachment #738809 - Flags: approval-mozilla-aurora+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.