If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Last Contact of a chunk is not rendered

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: alberto.pastor, Assigned: alberto.pastor)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.1 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Right now we are rendering in chunks of 20 so, STR:

- Import/Create 21 Contacts
- Close Contacts app
- Reopen Contacts

Expected:

21 Contacts are shown

Actual:

Last contact is not shown

This is a regression from Bug 848188
(Assignee)

Updated

5 years ago
blocking-b2g: --- → tef?
(Assignee)

Comment 1

5 years ago
Created attachment 738971 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9275

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #738971 - Flags: review?(francisco.jordano)
Comment on attachment 738971 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9275

Now after fixing the unit test looking great for me :)
Attachment #738971 - Flags: review?(francisco.jordano) → review+

Updated

5 years ago
blocking-b2g: tef? → tef+
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla-b2g/gaia/commit/59c59bffaaf4bd31db6a387b50125b8dff615a26
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Assignee: nobody → alberto.pastor

Updated

5 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
(Assignee)

Comment 4

5 years ago
v1-train: 9f537aa216f3c12725c8d1c5c9603370b6bc1c46
v1.0.1: fdd57a4454413dcbeb90a74b436dc80793ed1cd6
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed

Comment 5

5 years ago
Tested on an Inari with the following build information :

Build ID : 20130422054646
Git Commit Info : 2013-04-21 21:19:35
Gaia Repo : 55f009ff476687958decea8d9cc15791... (ellipsis at the end)

The above issue is re-occurring. Had some 200 contacts. Did the STR as in Comment 0. So checked and lost a relatively big chunk of contacts (lost contacts in T, U, V, W, X, Y, Z). Moreover, after the above STR, not able to tap on the last few alphabets in the side pane and directly jump to the contacts starting with that alphabet (say T, U, V, W, X, Y, Z).

I am not able to reproduce this more ofter, but I would say the repro frequency is about 80%

Comment 6

5 years ago
Verified fixed on the Inari Build ID: 20130429070204

Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/45aa5ba0ed53
Gaia: cf2d4136f0ebc66039637fdbeb72ed184dfbc0f2'

Also verified fixed on Unagi Build ID: 20130429070204

Environmental  Variables:
Kernel Date: Dec 5

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/49a908f052ec
Gaia: e26eadbc598bd09c80192016c1024a4a999a5361

Last contact appears correctly.

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.