accesskey attribute is not handled properly.

RESOLVED DUPLICATE of bug 79898

Status

()

RESOLVED DUPLICATE of bug 79898
17 years ago
17 years ago

People

(Reporter: pawee, Assigned: joki)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.1) Gecko/20010607
BuildID:    20010607

The problem occurs when I use accesskey attribue with input tags (of type text)
and textarea.

When pressing alt-accesskey, Mozilla gives focus on input field (cursor is
blinking there) but it doesn't allow typing in. It seems that Mozilla also gives
focus on menu at the same time. If I gained focus on one input field by using
accesskey and I type "s", Mozilla will drop down "Search" menu rather than
putting "s" in input field.

However, it works with submit and reset types input.

On IE, I don't have to click on any input field first, in order to use
accesskey. I simply press
alt-accesskey and it gives focus there and allows typing in.

Reproducible: Always
Steps to Reproduce:
1. Load a page with a form like this example:
<form>
<label for="name" accesskey="n">Name:</label>
<input type="text" name="Name" id="name" /><br />
<label for="msg" accesskey="m">Message:</label>
<input type="text" name="Message" id="msg" /><br />
<label for="submit" accesskey="s">Submit</label>/<label for="reset"
accesskey="r">Reset</label>
<input type="submit" value="Submit" id="submit" /><input type="reset"
value="Reset" id="reset" /><br />
</form>
2. Press alt-n, input field for Name will gain focus (blinking cursor)
3. Try pressing r, nothing happens.  (but notice the menu bar)
4. Press s, Mozilla drops down "Search" menu.
5. Click on any input field, type something in.
6. Use alt-r, form will be reset (correct).
7. Use alt-s, form will be submit (correct).

Actual Results:  As in description.

Expected Results:  At step 3, r should be put in the input field of Name. And
menu shouldnt gain focus.

accesskey attribute is supported by A, AREA, BUTTON, INPUT, LABEL, LEGEND, TEXTAREA
i don't know if the problem occurs with other elements too.
(Reporter)

Updated

17 years ago
Summary: accesskey attribute is not handle properly. → accesskey attribute is not handled properly.

Comment 1

17 years ago
This bug, at least the testcase seems to be a dup of 81479. If you put the
accesskey attribute on the inputbox itself things work. The accesskeys for the
labels of the buttons seem to work.

*** This bug has been marked as a duplicate of 81479 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Actually a dup of bug 79898.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 79898 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.