If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Firefox OS
Gaia
P1
normal
RESOLVED DUPLICATE of bug 863126
5 years ago
5 years ago

People

(Reporter: dpalomino, Assigned: gasolin)

Tracking

unspecified
x86_64
Windows 7

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Whiteboard: IOT)

(Reporter)

Description

5 years ago
Raised during certification, adding dep. 

Buildid "20130321070205", device: ikura
gecko commit: b5183c99228bdc5be33340e359efd1b4f0859e92 
gaia commit: 577d13088ebdbd353d13910d3317e713a140415b

APN names shown for different MCC/MNC are not correct, these are the correct ones: 

Country (MCC/MNC) - These are the correct ones: 

- Movistar México (334/30)
Shown = movistar Internet / Should be = Movistar INTERNET

- Guatemala (704/03)
Shown = unknown / Should be = Movistar INTERNET

- Salvador (706/04)
Shown = Internet SV / Should be = Movistar INTERNET

- Nicaragua (710/300)
Shown = Internet GPRS / Should be = Movistar INTERNET

- Costa Rica (712/04)
Shown = movistar INTERNET / Should be = Movistar INTERNET

- Panama (714/02)
Shown = movistar INTERNET / Should be = Movistar INTERNET

- Colombia (732/123)
Shown = movistar Internet / Should be = Movistar INTERNET

- Ecuador (740/00)
Shown = movistar Internet / Should be = Movistar INTERNET

- Uruguay (748/07)
Shown = Movistar Emoción / Should be = Movistar INTERNET

- Perú (716/06)
Shown = movistar Internet / Should be = Movistar INTERNET

- Venezuela (734/04)
Shown = movistar INTERNET / Should be = Movistar INTERNET    

- Chile (730/02)
Display: NEM / Should be: Movistar APLICACIONES

- Argentina (722/10)
Display: Movistar Emoción / Should be: Movistar WAP    

Bug nominated for tef?
We use the APN database from https://android.googlesource.com/device/sample/+/master/etc/apns-full-conf.xml. The names are in this database.
They must be modified to follow above rules.
(Assignee)

Comment 3

5 years ago
This issue will also be resolved by the patch for bug 863126
Assignee: nobody → gasolin
Shall we mark this bug as dup of bug 863126?
(Assignee)

Comment 5

5 years ago
in bug 863126, said

Chile
Display = NEM / Should be - Movistar INTERNET

compare with 

Chile (730/02)
Display: NEM / Should be: Movistar APLICACIONES

Is it should be 'Movistar INTERNET' to align other countries?
Flags: needinfo?(dpv)

Updated

5 years ago
blocking-b2g: tef? → tef+
Triage agrees this needs to be updated for tef per partner request.

also ni?:brg for comment 5
Flags: needinfo?(brg)
(Assignee)

Comment 7

5 years ago
Just talk with kaze, he says similar as José stated in comment 1.

We'd better submit the APN change to Android OpenSource Project(AOSP), and the APN will be pulled and updated in build stage.
Thinking a bit about this issue I'm wondering if we could show the name of the carrier [1] in the SIM in the APN setting sub panels instead of showing the value in the setting ril.{data, supl, mms}.carrier.

[1] http://mxr.mozilla.org/mozilla-central/source/dom/network/interfaces/nsIDOMMobileConnection.idl#496

Thoughts?
Relying on the SPN info (= the carrier name stored in the SIM card) wouldn’t solve our current issue, which is to get proper carrier names in the list of APN presets matching an MCC/MNC tuple.

However, it would be very useful for bug 863678, thanks for the suggestion.

Comment 10

5 years ago
Since this blocks certification, add IOT in the whiteboard.
Whiteboard: IOT
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 863126
Lets track this issue on bug 863126. The partner is asking the country OB to provide the right answer.
Clearing needinfo of dpv.
Flags: needinfo?(dpv)
Flags: needinfo?(brg)
You need to log in before you can comment on or make changes to this bug.