nav-bar customization target has too much flex

RESOLVED FIXED in Firefox 28

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

Trunk
Firefox 28
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

STR:

1) Using a new profile in a UX build, enter Customize mode, and remove the search input from the nav-bar
2) Restart the browser

Result:

The customization target in the nav-bar is very wide - too wide for the number of elements it contains (the download button and the "Share" button).

Expected result:

The customization target should calculate its appropriate flex by using the flex attributes of its children.
Created attachment 739133 [details] [diff] [review]
Patch v1

Seems to do the job. CustomizableUI.jsm already does the job of setting the target's flex to the right value when adding or removing widgets.
Assignee: nobody → mconley
Status: NEW → ASSIGNED
Attachment #739133 - Flags: review?(jaws)
Comment on attachment 739133 [details] [diff] [review]
Patch v1

Review of attachment 739133 [details] [diff] [review]:
-----------------------------------------------------------------

So the flex value will be correct at initial startup when the search box and other toolbaritems are added to the customization target?
Attachment #739133 - Flags: review?(jaws) → review+
(In reply to Jared Wein [:jaws] from comment #2)
> Comment on attachment 739133 [details] [diff] [review]
> Patch v1
> 
> Review of attachment 739133 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> So the flex value will be correct at initial startup when the search box and
> other toolbaritems are added to the customization target?

Yeah, when we start up CustomizableUI, we build the customizable areas, and start stuffing things into the customization targets. When we do that, we automatically set the flex on the parents.
Comment on attachment 739133 [details] [diff] [review]
Patch v1

This will be fixed as a consequence of bug 864355.
Attachment #739133 - Attachment is obsolete: true
Fixed as a consequence of bug 864355.
Whiteboard: [fixed-in-jamun]
Duplicate of this bug: 858584
Whiteboard: [fixed-in-jamun] → [fixed-in-jamun][fixed-in-ux]
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-jamun][fixed-in-ux]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.