If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Inspect Element + responsive layout puts black box in the corner

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Greg Edwards, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130418 Firefox/23.0
Build ID: 20130418031048

Steps to reproduce:

Navigate to a Gmail inbox.
Resize your browser window to about 1024x768 or just big enough to make Gmail use its biggest layout.
Right click an element and choose Inspect Element.
Close the inspector.


Actual results:

A black box appears stuck in the lower left corner, corresponding to the size of the last hyperlink tooltip which was shown there.


Expected results:

It shouldn't show anything there.

I can replicate on Windows 7 using Firefox 20 through to Nightly 23. I can't replicate on OSX.
(Reporter)

Updated

5 years ago
Component: Untriaged → Developer Tools: Inspector

Comment 1

4 years ago
Well, this bug is not specific to Gmail or any other website. It happens every time when the Developer Tools are closed. If you point to a hyperlink with your mouse, the usual status tooltip or hyperlink tooltip (or how to call that) shows in the lower left corner with. When you mouse out of the hyperlink, a black rectangle remains with the exact size of the tooltip for the hyperlink just left with the mouse.

I can confirm that this bug has been present for some time and is still present in Firefox 23 Beta I am using right now.
I can't reproduce on FF 23b1, 23RC Win 7 x64.
(Reporter)

Comment 3

4 years ago
Neither can I using steps that previously worked for me. Can anyone bisect? I'm curious what could have fixed this, and still a little unsure if it's really fixed or if that case just went away.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(In reply to Greg Edwards from comment #3)
> Can anyone bisect?
You can do it very easily with the mozregression tool
http://harthur.github.com/mozregression/
You need to log in before you can comment on or make changes to this bug.