Move publishing to makes.org

RESOLVED FIXED

Status

Webmaker
Popcorn Maker
--
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: humph, Assigned: jbuck)

Tracking

Details

(Whiteboard: s=2013w24 p=1)

(Reporter)

Description

5 years ago
In the new Webmaker, Popcorn Maker projects will be published to a user-domain.  For example, if I'm logged in as `humph` and I create a project called `kittens`, I'd expect to see this at:

humph.floopy.org/kittens

Internally this still goes into S3 as before, but probably namespaced on the user/domain.  It also uses the name provided by the user instead of the base36 string for the project ID--we might choose to use that base36 ID string as the default name, and let the user provide a new name as they like.
(Reporter)

Comment 1

5 years ago
See also bug #863368 for parallel work in Thimble.
See Also: → bug 862912
(Assignee)

Updated

5 years ago
Duplicate of this bug: 873564
(Assignee)

Updated

5 years ago
Assignee: schranz.m → jon
(Assignee)

Updated

5 years ago
Whiteboard: s=2013w20ical
(Assignee)

Updated

5 years ago
Whiteboard: s=2013w20ical → s=2013w20
jbuck, what's keeping this from landing?
Whiteboard: s=2013w20 → s=2013w21
(Assignee)

Comment 4

5 years ago
I did not get the code for Popcorn working last week
Jbuck, we now have makes.org - can we land patches in popcorn and thimble to enable publishing there?

Updated

5 years ago
Whiteboard: s=2013w21 → s=2013w22

Updated

5 years ago
Whiteboard: s=2013w22 → u=user p=1 s=2013w22
(Assignee)

Updated

5 years ago
Whiteboard: u=user p=1 s=2013w22 → s=2013w23

Updated

5 years ago
Whiteboard: s=2013w23 → s=2013w24

Updated

5 years ago
Whiteboard: s=2013w24 → s=2013w24 p=1

Updated

5 years ago
Summary: Move publishing to Webmaker user-domains → Move publishing to makes.org
Severity: enhancement → blocker
Duplicate of this bug: 880832
This was fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

5 years ago
Sadly it hasn't landed yet
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ah sorry. I was getting into blockception with different bugs.
Blocks: 876457
Is there anything I can do to help this along?

Comment 11

5 years ago
Commit pushed to master at https://github.com/mozilla/popcorn.webmaker.org

https://github.com/mozilla/popcorn.webmaker.org/commit/4e0d33a4514753d8112b3bc43d26f592645b0018
Fix Bug 863366 - Add support for publishing to custom domain and user subdomains

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Blocks: 883481
You need to log in before you can comment on or make changes to this bug.