Rotation takes 5 times as long in Beta as in current Firefox for screen to reach full width

RESOLVED DUPLICATE of bug 847348

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 847348
5 years ago
2 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

21 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

In Firefox Beta and Firefox loaded numerous websites and then rotated between portrait and landscape. (On a Nexus 4)


Actual results:

In Firefox Beta, after rotation, you'll see:

1. The browser and screen rotate

2. A 1+ second delay where (moving from portrait to landscape) the web page is only 1/3 the width and there's just gray to the right or (moving to landscape from portrait) the web page is too wide for the screen before finally sizing back down.

In Firefox, the instant the rotation of Firefox occurs, the web page is also properly sized.



Expected results:

It should have had zero delay after rotation.

There's no delay in the following browsers:

1. Firefox Release
2. Chrome
3. Opera Mobile
4. Dolphin

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 847348
You need to log in before you can comment on or make changes to this bug.