[Task switcher] Sometimes tap events are fired during fast scroll

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

unspecified
x86
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Viven and me have detected what tap events are fired while scrolling
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Depends on: 859259
(Assignee)

Comment 1

5 years ago
Created attachment 739501 [details]
Patch v1

Right now, there is only one listener for tap events (no such as cards) and the click feature is disabled during cards are translating
Attachment #739501 - Flags: review?(21)
(Assignee)

Comment 2

5 years ago
upps sorry Vivien :) I wrote "Viven"
(In reply to Cristian Rodriguez (a tope!) from comment #2)
> upps sorry Vivien :) I wrote "Viven"

No problem Christan ;P
(In reply to Cristian Rodriguez (a tope!) from comment #2)
> upps sorry Vivien :) I wrote "Viven"

No problem Cristan ;P
(Assignee)

Comment 5

5 years ago
https://github.com/crdlc/gaia/commit/c949b079871cffe742eaaf361f218969a784d438
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
It should be on v1-train after uplifting this bug 859259
blocking-b2g: --- → leo?

Comment 7

5 years ago
Please nominate for approval-gaia-v1 to make it into v1.1
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Flags: needinfo?(crdlc)
(Assignee)

Comment 8

5 years ago
Comment on attachment 739501 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 859259
User impact if declined: medium, sometimes unexpected clicks happens 
Testing completed: yes
Risk to taking this patch (and alternatives if risky): close to null
String or UUID changes made by this patch:
Attachment #739501 - Flags: approval-gaia-v1?
Flags: needinfo?(crdlc)

Updated

5 years ago
Attachment #739501 - Flags: approval-gaia-v1? → approval-gaia-v1+
Uplifted dfde9dd8b0b78fdc1fcc05d595ee41c689aebd0e to:
v1-train: 04fd53b9e63bc695411b8dac59db0525965f8262
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.